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Product Overview

Product Overview
Simulink® Parameter Estimation™ software is a Simulink-based product for
estimating and calibrating model parameters from experimental data. This
product supports the following types of estimation:

• Transient Estimation — Estimate parameters by comparing model output
to the experimental data for a given input.

• Initial Condition Estimation — Estimate the initial conditions of states
using experimental data.

• Adaptive Lookup Tables — Estimate the table values at the prescribed
breakpoints by using measurements from the physical system.

Simulink Parameter Estimation software provides the tools used to:

1 Set up the problem.

2 Specify which model parameters to estimate.

3 Import and prepare the experimental data for parameter estimation (or
preprocess).

4 View the estimation progress.

5 Validate the estimation results based on plots of measured versus.
simulated data and residuals.
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What You Need to Get Started

In this section...

“Prerequisite Software and Optional Software” on page 1-4

“Required Knowledge” on page 1-4

“Demos” on page 1-4

Prerequisite Software and Optional Software
Simulink® Parameter Estimation™ software requires MATLAB® technical
computing software, Simulink® software, and Optimization Toolbox™
software.

Several of The MathWorks™ products are relevant to the kinds of task
you can perform with Simulink Parameter Estimation software. For more
information about any of these products, see the

• MathWorks Web site at
http://www.mathworks.com/products/simparameter/related.jsp

• Online documentation for related products, if they are installed on your
system

Required Knowledge
It is not necessary that you have a strong background in optimization theory
or practice. As you gain familiarity with Simulink Parameter Estimation
software, you might find it helpful to consult the Optimization Toolbox
documentation for more details about optimization algorithms.

Demos
Simulink Parameter Estimation demonstration files show you how to use the
software to perform control design tasks in various settings. To run these
demos, type

demo

1-4
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What You Need to Get Started

at the MATLAB prompt. This opens the Demos pane in the Help browser.
Select Simulink > Simulink Parameter Estimation to list the available
demos. Alternatively, if you have the Help browser open, you can select the
Demos pane in the Help browser and then select Simulink > Simulink
Parameter Estimation.
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How Simulink® Parameter Estimation™ Software Works

In this section...

“Basic Steps in the Estimation Process” on page 1-6

“Structure of an Estimation Project” on page 1-7

“Adding, Deleting and Renaming an Estimation Project” on page 1-8

Basic Steps in the Estimation Process
Simulink® Parameter Estimation™ software compares empirical data with
data generated by a Simulink® model. Using optimization techniques, the
software estimates the parameter and (optionally) initial conditions of states
such that a user-selected cost function is minimized. The cost function
typically calculates a least-square error between the empirical and model
data signals.

After you build a Simulink model, follow these steps to configure and run a
parameter estimation:

1 Select Tools > Parameter Estimation in your Simulink model window.

This opens the Control and Estimation Tools Manager, creates a new
project, and adds an Estimation node to the workspace directory tree.

2 Import the input and output data set for estimating parameters of your
Simulink model.

3 Select the parameters and initial conditions you want to estimate.

4 Configure the estimation itself, including cost functions and data views.

5 Run the estimation.

6 Check the results by examining either the cost-function values, plots, or
parameter values.
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Structure of an Estimation Project
The Control and Estimation Tools Manager, which is a graphical user
interface (GUI) for performing parameter estimation, stores and organizes
all data from a given Simulink model inside a project. To open the Control
and Estimation Tools Manager GUI, select Tools > Parameter Estimation
in the Simulink model window. See Control and Estimation Tools Manager
GUI on page 1-11 for a picture showing this GUI.

When using the Control and Estimation Tools Manager for parameter
estimation, you can

• Manage estimation projects.

• Select parameters and initial conditions to configure the estimation.

• Specify cost functions.

• Import experimental data (to be matched by the output of your Simulink
model).

• Specify the initial conditions of your model.

Each estimation task can include

• One or more data sets

• Parameter information

• One or more sets of estimation settings, or configurations

The default project name is the same as the Simulink model name. The
project name is shown in the workspace directory tree of the Control and
Estimation Tools Manager.

You can also add tasks from Simulink® Control Design™ and Model Predictive
Control Toolbox™ software to the current project, if these products are
installed on your system.
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Adding, Deleting and Renaming an Estimation Project
To add, delete, or rename the project or task:

1 Right-click the project or task node in the workspace directory tree.

2 Select the appropriate command from the shortcut menu.
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Setting Up the Estimation Data

In this section...

“Adding Ports and Test Points to the Model” on page 1-9

“Creating an Estimation Project” on page 1-10

“Importing Transient Data” on page 1-11

“Specifying Initial Conditions” on page 1-16

“Selecting Parameters for Estimation” on page 1-17

“Selecting States for Estimation” on page 1-19

“Specifying Initial Guesses and Upper/Lower Bounds” on page 1-20

Adding Ports and Test Points to the Model
To enable importing data, the Simulink® model for which you want to estimate
parameters must contain one of the following:

• Input and output ports

Every top-level port in the model creates a row in the GUI for importing
data for the corresponding input or output. When you add a port to the
model, a new row is added in the corresponding Input Data or Output
Data tab.

• Test points marked for signal logging

Every test point marked for signal logging in the model creates a row in the
GUI for importing output data . When you add a test point to a signal for
signal logging, a new row is added in the Output Data tab.

For more information, see the Inport and Outport block reference pages and
“Working with Test Points” in the Simulink documentation.

The engine_idle_speed model used in this example contains one Inport
block BPAV and one Outport block Engine Speed that are used for importing
measured input and output data.
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Creating an Estimation Project
Before beginning the estimation process, you must create an estimation
project and set up the problem by configuring the appropriate parameters,
solvers, and cost functions.

Simulink® Parameter Estimation™ software provides a Graphical User
Interface (GUI) that makes setting up the estimation project quick and easy.
This section describes how to use the GUI to estimate parameters.

To perform the setup,

1 Open the nonlinear idle speed model of an automotive engine by typing :

engine_idle_speed

at the MATLAB® prompt.

The model appears as shown next.

2 Open the Control and Estimation Tools Manager GUI by selecting Tools
> Parameter Estimation in the Simulink model window.
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The project tree displays the project name Project - engine_idle_speed.
Estimation tasks are organized inside the Estimation Task node.

Control and Estimation Tools Manager GUI

Importing Transient Data
To import transient (measured) data for your dynamic system:

1 In the Control and Estimation Tools Manager, select Estimation Task
> Transient Data in the workspace directory tree.

2 Right-click Transient Data and select New to create a New Data node.
Alternatively, you can use the New button to create this node.

1-11



1 Getting Started

3 Select the New Data node in the workspace directory tree.
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Import Data into the Control and Estimation Tools Manager

You see a row for importing data for the input port BPAV in the Input Data
tab. The Output Data tab shows a row for importing data for the output
port Engine Speed.

Tip If you have estimation data for any other signal in your model, add a
port or a test point to the signal to create a new row for importing the data.

Importing Input Data
To import the model input data for the input port BPAV:

1 In the New Data node, click the Input Data tab.

1-13



1 Getting Started

2 Right-click the Data cell and select Import to open the Data Import dialog
box. Alternatively, you can use the Import button to open this dialog box.

3 In the Data Import dialog box, select iodata from the list of variables.
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The idle-speed model of an automotive engine contains the measured data
stored in the iodata array. The array contains two columns: the first for
model input data, and the second for model output data.

4 Enter 1 in the Assign the following columns to selected channel(s)
field, and then click Import.

5 Click the Time/Ts cell, and select time in the Data Import dialog box.

6 Click Import to import the time vector for the input data.

7 Click Close to close the Data Import dialog box.

Importing Output Data
To import the model output data for the output port Engine Speed:

1 In the New Data node, click the Output Data tab.

2 Right-click the Data cell and select Import to open the Data Import dialog
box.

3 Select iodata from the list of variables.

4 Enter 2 in the Assign the following columns to selected channel(s)
field to use the second column of iodata, and then click Import.
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5 Click the Time/Ts cell, and select time in the Data Import dialog box.

6 Click Import to import the time vector for the output data.

7 Click Close to close the Data Import dialog box.

Specifying Initial Conditions
By default, the estimation uses initial conditions specified in the Simulink
model. If you want to specify initial conditions other than the defaults, use
the State Data tab. You can open it by selecting Transient Data > New
Data in the workspace directory tree, and then clicking the State Data tab.

1-16



Setting Up the Estimation Data

To specify an initial condition of a state:

1 Select the Data cell associated with the state.

2 Enter the initial conditions. In this example, enter -0.2 for State - 1 of
the engine_idle_speed/Transfer Fcn. For State - 2, enter 0.

Selecting Parameters for Estimation
To select parameters for estimation:

1 In the Control and Estimation Tools Manager, select the Variables node in
the workspace directory tree to open the Estimated Parameters pane.

2 In the Estimated Parameters pane, click Add to open the Select
Parameters dialog box.
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3 Select the last seven parameters: freq1, freq2, freq3, gain1, gain2,
gain3, and mean_speed, and then click OK.

In general, you can enter parameters, (separated by commas, in the Specify
expression field. The parameters can be stored in one of the following:

• Simulink software parameter object

Example: For a Simulink parameter object k, type k.value.

• Structure

Example: For a structure S, type S.fieldname (where fieldname represents
the name of the field that contains the parameter).

• Cell array

Example: Type C{1} to select the first element of the C cell array.

• MATLAB array

Example: Type a(1:2) to select the first column of a 2-by-2 array called a.

1-18



Setting Up the Estimation Data

Note You need not estimate the parameters selected here all at once. You
can first select all the parameters that you are interested in, and then later
decide which ones to estimate in a particular estimation.

Often, it is more practical to estimate a small group of parameters and use the
final estimated values as a starting point for further estimation of parameters
that are trickier. Making these sorts of choices involves experience, intuition,
and a solid understanding of the strengths and limitations of your Simulink
model.

Sometimes models have parameters that are not explicitly defined in the
model itself. For example, a gain k could be defined in the MATLAB
workspace as k=a+b, where a and b are not defined in the model but k is used.
To add these independent parameters to the Select Parameters dialog box, see
“Estimating Independent Parameters” on page 1-58.

Selecting States for Estimation
In general, you choose to estimate only those states that are not already in the
model. To estimate initial conditions (or initial states) if they are not known:

1 In the Control and Estimation Tools Manager, select the Variables node in
the workspace directory tree.

2 Click the Estimated States tab.

3 Click Add to open the Select States dialog box.
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4 Examine the available states but do not select any for this example.

Specifying Initial Guesses and Upper/Lower Bounds
After you select parameters for estimation, the Control and Estimation Tools
Manager looks like the following figure.
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For each parameter, use the Default settings pane to specify the following:

• Initial guess — The value the estimation uses to start the process.

• Minimum — The smallest allowable parameter value. The default is -Inf.

• Maximum — The largest allowable parameter value. The default is +Inf.

• Typical value — The average order of magnitude. If you expect your
parameter to vary over several orders of magnitude, enter the number
that specified the average order of magnitude you expect. For example, if
your initial guess is 10, but you expect the parameter to vary between
10 and 1000, enter 100 (the average of the order of magnitudes) for the
typical value.
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You use the typical value in two ways:

• To scale parameters with radically different orders of magnitude for equal
emphasis during the estimation. For example, try to select the typical
values so that

anticipated value
typical value

≅ 1

or

initial value
typical value

≅ 1

• To put more of less emphasis on specific parameters. Use a larger typical
value to put more emphasis on a parameter during estimation.
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Setting Up an Estimation Project

In this section...

“Creating an Estimation Task” on page 1-23

“Adding Data Sets” on page 1-23

“Specifying and Setting Up Parameters” on page 1-25

“Specifying Settings for Estimation” on page 1-27

Creating an Estimation Task
After you import the transient data and select the parameters and any
initial conditions (or states) to estimate, you must create an estimation task
and configure the estimation settings. To create a container that stores the
estimation settings:

1 In the Control and Estimation Tools Manager, right-click Estimation in
the workspace directory tree and select New.

2 Click the New Estimation node.

Adding Data Sets
After you select the New Estimation node, the Data Sets tab appears. Here
you choose the output data from the Simulink® model that you want to use
in the estimation.

In this example, select the check box to the right of the New Data data set.
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Note If you imported multiple data sets, you can select them for estimation
by selecting the check box to the right of each desired data set. When using
several data sets, you increase the estimation precision. However, you also
increase the number of required simulations: for N parameters and M data
sets, there are M*(2N+1) simulations per iteration.

Then, specify the weight of each output from this model by setting the Weight
column in the Output data weights table.

The relative weights are used to place more or less emphasis on specific
output variables. The following are a few guidelines for specifying weights:

• Use less weight when an output is noisy.

• Use more weight when an output strongly affects parameters.
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• Use more weight when it is more important to accurately match this model
output to the data.

Specifying and Setting Up Parameters
In the New Estimation node in the workspace directory tree, click the
Parameters tab in the Control and Estimation Tools Manager. In this pane,
you select which parameters to estimate and the range of values for the
estimation.

Note When you specify the Minimum and Maximum values for the
parameters here, it does not affect your settings in the Variables node. You
make these choices on a per estimation basis. You can move data to and from
the Variables node into the Estimation node.
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You can select the parameters you want to estimate by selecting the check
box in the Estimate column. Enter initial values for your parameters in the
Initial Guess column. The default values in the Minimum and Maximum
columns are -Inf and +Inf, respectively, but you can select any range you
want.

For this example, set gain1 to 10, gain2 to 100, gain3 to 50, and mean_speed
to 500. Alternatively, use any initial values you like.

If you have good reason to believe a parameter lies within a finite range, it is
usually best not to use the default minimum and maximum values. Often,
there are computational advantages in specifying finite bounds if you can. It
can be very important to specify lower and upper bounds. For example, if a
parameter specifies the weight of a part, be sure to specify 0 as the absolute
lower bound if better knowledge is unavailable.
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Specifying Settings for Estimation
In the New Estimation node in the workspace directory tree, click the
Estimation tab to specify the settings for estimation.

Before you start, you can click Estimation Options to specify various
algorithms and simulation features. See “Setting Options for Optimization”
on page 1-46for more information.

Display Options
You can specify the display options by clicking Display Options. This opens
the following dialog box.
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Clearing a check box implies that feature will not appear in the display table
as the estimation progresses.
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Selecting Views for Plotting

In this section...

“Basic Steps for Creating Plots” on page 1-29

“Types of Plots” on page 1-32

Basic Steps for Creating Plots

Note An estimation must be created before creating views. Otherwise, the
Options table will be empty.

To create plots for viewing the estimation progress, follow the steps below:

1 Right-click the Views node in the Control and Estimation Tools Manager
and select New.
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2 In the workspace directory tree, select New View to open the View Setup
pane.
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3 In the Select plot types table, select the Plot Type from the drop-down
list. In this example, select Cost function.

4 Select Measured and simulated as the Plot Type for Plot 2. This plot
will be used in “Performing Validation” on page 1-39.

5 In the Options area, select the check-box for both Plot 1 and Plot 2.

6 Click Show Plots. This displays an empty cost function plot and a plot
of the measured data. When you run the estimation, the plot updates
automatically.

The next figure shows the plot generated by running the estimation, as
described in “Running the Estimation” on page 1-33.
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Types of Plots
You can choose the plot type from the drop-down list under Plot Type.
Various types of plots are available, including

• Cost function — Plot the cost function values.

• Measured and simulated — Plot empirical data against simulated data.

• Parameter sensitivity — Plot the rate of change of the cost function as a
function of the change in the parameter. That is, plot the derivative of the
cost function with respect to the parameter being varied.

• Parameter trajectory — Plot the parameter values as they change.

• Residuals — Plot the error between the experimental data and the
simulated output.
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Running the Estimation
In the Control and Estimation Tools Manager, select the New Estimation
node and click the Estimation tab.

Click Start to begin the estimation process. At the end of the iterations, the
window should resemble the following:

Usually, a lower cost function value indicates a successful estimation,
meaning that the experimental data matches the model simulation with the
estimated parameters.

The Estimation pane displays each iteration of the optimization algorithm.
To see the final values for the parameters, click the Parameters tab.
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The values of these parameters are also updated in the MATLAB® workspace.
If you specify the variable name in the Initial Guess column, you can restart
the estimation from where you left off at the end of a previous estimation.

After the estimation process completes, the cost function minimization plot
appears as shown in the following figure.
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If the optimization went well, you should see your cost function converge on a
minimum value. The lower the cost, the more successful is the estimation.
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Model Validation

In this section...

“Basic Steps for Model Validation” on page 1-36

“Example: Validating the Engine Idle Speed Model” on page 1-37

“Loading and Importing the Validation Data” on page 1-38

“Performing Validation” on page 1-39

“Comparing Residuals” on page 1-43

Basic Steps for Model Validation
After you complete estimating the parameters, you can validate your results
against another set of data.

These are the basic steps needed to validate a model using the Control and
Estimation Tools Manager:

1 Add the validation data set to the Transient Data node.

2 Add a new validation task in the Validation node in the workspace
directory tree.

3 Configure the validation settings by selecting the plot types and the
validation data set from the Validation Setup pane.

4 Click Show Plots in the Validation Setup pane and view the results in
the plot window.

5 Compare the validation plots to the corresponding view plots to see if
they match.

The basic difference between the validation and views features is that you
can run validation after the estimation is complete. All views should be set
up before an estimation, and you can watch the views update in real time.
Validations can use other validation data sets for comparison with the model
response. Also, validations appear after you have completed an estimation
and do not update.
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You can validate your data by comparing measured vs. simulated data for
your estimation data and validation data sets. Also, it is often useful to
compare residuals in the same way.

Example: Validating the Engine Idle Speed Model
If you have not run the engine idle speed demo, type:

engine_idle_speed

at the MATLAB® prompt and run the estimation. For more information on
how to run the estimation, see “How Simulink® Parameter Estimation™
Software Works” on page 1-6. You can double-click the box in the upper-left
corner of the model to import data and populate the required fields in the
Control and Estimation Tools Manager.

engine_idle_speed Simulink® Model

Now that the estimation data is loaded, and the estimation task has been
created, the next step is to import validation data into the Control and
Estimation Tools Manager.
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Loading and Importing the Validation Data
To load the validation data, type

load iodataval

at the MATLAB prompt. This loads the data into the MATLAB workspace.
The next step is to import this data into the Control and Estimation Tools
Manager. See “Importing Transient Data” on page 1-11 for information on
importing data, but the quickest way is to follow these steps:

1 Right-click the Transient Data node in the workspace directory tree in
the Control and Estimation Tools Manager and select New.

2 Select New Data (2) from the Transient Data pane.

3 Right-click the New Data (2) node in the workspace directory tree and
select Rename. Change the name of the data to Validation Data.

4 In the Input Data pane, select the Data cell associated with Channel
- 1 and click Import. In the Data Import dialog box, select iodataval
and assign column 1 to the selected channel by entering 1 in the Assign
columns field. Click Import to import the input data.

5 Select the Time/Ts cell and import time using the Data Import dialog box.
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6 Similarly, in the Output Data pane, select Time/Ts and import time.

7 In the Output Data pane, select the Data cell associated with Channel
- 1 and click Import. Import the second column of data in iodataval by
selecting it from the list in the Import Data dialog box and entering 2 in the
Assign columns field. Click Import to import the output data.

Your Control and Estimation Tools Manager should resemble this figure.

Performing Validation
After you import the data, right-click the Validation node and select New.
This creates a New Validation node in the Control and Estimation Tools
Manager.
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To perform the validation:

1 Select New Validation in the workspace directory tree to open the
Validation Setup pane.
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2 Click the Plot Type cell for Plot 1 and select Measured and simulated
from the drop-down menu.

3 In the Options area, select Validation Data in the Validation data set
drop-down list.

4 Click Show Plots to open a plot figure window as shown next.
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Measured Versus Simulated Data Plot for Validation Data

5 Compare this plot with the plot of Measured and simulated data for
the validation data. For more information on how to create this plot, see
“Selecting Views for Plotting” on page 1-29.
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Measured and Simulated Data Views Plot

Comparing Residuals
To look at the residuals, select Residuals as the Plot Type for Plot 2 in the
New Validation pane. In the Options area, select the Plot 2 check box and
click Show Plots. The following figure shows the resulting residuals plot.
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Plot of Residuals Using the Validation Data

Compare the validation data residuals with the original data set residuals
from the Views node in the workspace directory tree. To create the plot of
residuals for the original data set, select the New View node and choose
Residuals as the Plot Type.
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Plot of Residuals Using the Test Data

The plot on the left agrees with the plot of the residuals for the validation
data. The right side has no plot because residuals were not calculated for the
validation data during the original estimation process.
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Setting Options for Optimization

In this section...

“Tuning the Results of Optimization” on page 1-46

“Selecting Optimization Methods” on page 1-47

“Selecting Optimization Termination Options” on page 1-48

“Selecting Additional Optimization Options” on page 1-49

“Specifying the Cost Function” on page 1-49

Tuning the Results of Optimization
You can set several options to tune the results of the optimization. These
options include the optimization algorithms and their tolerances.

To set options for optimization:

1 Select the New Estimation node in the workspace directory tree.

2 Click the Estimation tab.

3 Click Estimation Options to open the Options dialog box.
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4 Click the Optimization Options tab and specify the options, as described
in the following sections:

Selecting Optimization Methods
Both the algorithm and model size define the optimization method. Use the
Optimization method area in the Options dialog box to set algorithm and
the model size.

For the Algorithm parameter, the four options are

• Gradient descent — Uses the Optimization Toolbox™ function fmincon
to optimize the response signal subject to the constraints

• Nonlinear least squares — Uses a nonlinear least squares optimization
algorithm.

• Pattern search — Uses an advanced pattern search algorithm. This
option requires Genetic Algorithm and Direct Search Toolbox™ software.
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• Simplex search — Uses the Optimization Toolbox function fminsearch,
which is a direct search method to optimize the response. Simplex search
is most useful for simple problems and is sometimes faster than Function
minimization for models that contain discontinuities.

For Model size, the two options are Large scale and Medium scale. By
default, Model size is set to Large scale. The Large scale methods will
always run faster, if there is some sparsity structure in the Jacobian (or
Hessian) that can be taken advantage of.

For more information on these algorithms, refer to “Medium-Scale
Algorithms”, “Large-Scale Algorithms”, and “Standard Algorithms” in the
Optimization Toolbox documentation.

Selecting Optimization Termination Options
Specify termination options in the Optimization options area.

Several options define when the optimization terminates:

• Diff max change — The maximum allowable change in variables
for finite-difference derivatives. See fmincon in the Optimization
Toolboxdocumentation for details.

• Diff min change — The minimum allowable change in variables for
finite-difference derivatives. See fmincon in the Optimization Toolbox
documentation for details.

• Parameter tolerance — Optimization terminates when successive
parameter values change by less than this number.

• Maximum fun evals — The maximum number of cost function
evaluations allowed. The optimization terminates when the number of
function evaluations exceeds this value.
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• Maximum iterations — The maximum number of iterations allowed. The
optimization terminates when the number of iterations exceeds this value.

• Function tolerance — The optimization terminates when successive
function values are less than this value.

By varying these parameters, you can force the optimization to continue
searching for a solution or to continue searching for a more accurate solution.

Selecting Additional Optimization Options
At the bottom of the Optimization options pane is a group of additional
optimization options.

Additional options for optimization include

• Display level — Specifies the form of the output that appears in the
MATLAB® command window. The options are Iteration, which displays
information after each iteration, None, which turns off all output, Notify,
which displays output only if the function does not converge, and Final,
which only displays the final output. Refer to the Optimization Toolbox
documentation for more information on what type of iterative output each
algorithm displays.

• Gradient type — When using Gradient Descent or Nonlinear least
squares as the Algorithm, the gradients are calculated based on finite
difference methods. The Refined method offers a more robust and less
noisy gradient calculation method than Basic, although it does take longer
to run optimizations using the Refined method.

Specifying the Cost Function
The cost function is a function that optimization algorithms attempt to
minimize. You have the following options when selecting a cost function:

• Cost function — The default is SSE (sum of squared errors), which uses a
least-squares approach. You can also use SAE, the sum of absolute errors.
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• Use robust cost — Makes the optimizer use a robust cost function instead
of the default least-squares cost. This is useful if the experimental data has
many outliers, or if your data is noisy.
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Setting Options for the Simulation

In this section...

“Specifying Simulation Options” on page 1-51

“Selecting Simulation Time” on page 1-52

“Selecting Solvers” on page 1-53

Specifying Simulation Options
To optimize the response signals of a model, Simulink® Parameter
Estimation™ software runs simulations of the model.

To set options for simulation:

1 Select the New Estimation node in the workspace directory tree.

2 Click the Estimation tab.

3 Click Estimation Options to open the Options dialog box.
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4 Click the Simulation Options tab and specify the options, as described in
the following sections.

Selecting Simulation Time

By default, Start time and Stop time are automatically computed based on
the start and stop times specified in the Simulink® model.

To set alternative start and stop times for the optimization, enter them under
Simulation time. This action overwrites the simulation start and stop times
specified in the Simulink model.

Simulation Time for Data Sets with Different Time Lengths
Simulink Parameter Estimation software can simulate models containing
empirical data sets of different time lengths. You can use experimental data
sets for estimation that contain I/O samples collected at different time points.

The following example shows a single-input, two-output model for which
you want to estimate the parameters.

����

�����

�����

The model uses two output data sets containing transient data samples for
parameter estimation:

• Output y1(t) at time points t t t tn1 1
1

2
1 1= { }, ,.... .

• Output y2(t) at time points t t t tm2 1
2

2
2 2= { }, ,..... .

The simulation time t is computed as:
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t t t t t t t t tn m= ∪ = { }1 2 1
1

1
2

2
1

2
2 1 2, , , ,..... ,

This new set ranges from tmin to tmax. The values tmin and tmax represent
the minimum and maximum time points in t respectively.

When you run the estimation, the model is simulated over the time range t.
Simulink extracts the simulated data for each output based on the following
criteria:

• Start time — Typically, the start time in the Simulink model is set to 0.
For a nonzero start time, the simulated data corresponding to time points

before t1
1 for y1(t) and t1

2 for y2(t) are discarded.

• Stop time — If the stop time t tstop ≥ max , the simulated data
corresponding to time points in t1 are extracted for y1(t). Similarly, the
simulated data for time points in t2 are extracted for y2(t).

If the stop time t tstop < max , the data spanning time points > tstop are
discarded for both y1(t) and y2(t).

Selecting Solvers

When running the simulation, the dynamic system is solved using one of
several Simulink solvers. You can specify several solver options using the
Solver options area in the Options dialog box. The Type of solver can be
variable-step or fixed-step. Variable-step solvers keep the error within
specified tolerances by adjusting the step-size the solver uses. Fixed-step
solvers use a constant step-size. When your model’s states are likely to vary
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rapidly, a variable-step solver is often faster. See the Simulink documentation
for information about solvers.

Variable-Step Solvers
When you select Variable-step as the solver Type, you can choose any of
the following as the Solver:

• discrete (no continuous states)

• ode45 (Dormand-Prince)

• ode23 (Bogacki-Shampine)

• ode113 (Adams)

• ode15s (stiff/NDF)

• ode23s (stiff/Mod. Rosenbrock)

• ode23t (Mod. stiff/Trapezoidal)

• ode23tb (stiff/TR-BDF2)

Variable-Step Solver Options
When you select Variable-step as the Simulink solver Type, you can also
set several other parameters that affect the step-size of the simulation:

• Maximum step size — The largest step-size the solver can use during a
simulation.

• Minimum step size — The smallest step-size the solver can use during a
simulation.

• Initial step size — The step-size the solver uses to begin the simulation.

• Relative tolerance — The largest allowable relative error at any step in
the simulation.

• Absolute tolerance — The largest allowable absolute error at any step in
the simulation.

• Zero crossing control — Set to on for the solver to compute exactly
where the signal crosses the x-axis. This is useful when using functions
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that are nonsmooth and the output depends on when a signal crosses the
x-axis, such as absolute values.

By default, the values for these options are automatically chosen. To choose
your own values, enter them in the appropriate fields.

Fixed-Step Solvers
When you select Fixed-step as the solver Type, you can choose any of the
following as the Solver:

• discrete (no continuous states)

• ode5 (Dormand-Prince)

• ode4 (Runge-Kutta)

• ode3 (Bogacki-Shanpine)

• ode2 (Heun)

• ode1 (Euler)

When you select Fixed-step as the solver Type, you can also set Fixed step
size, which determines the step-size the solver uses during the simulation.
By default, a value for this option is automatically chosen.
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Accelerating the Estimation

In this section...

“About Accelerating Estimation” on page 1-56

“Limitations” on page 1-56

“Setting the Accelerator Mode for Parameter Estimation” on page 1-56

About Accelerating Estimation
You can accelerate the parameter estimation computations by changing
the simulation mode of your Simulink® model. Simulink® Parameter
Estimation™ software supports Normal and Accelerator simulation modes.
For more information about these modes, see “Accelerating Models” in the
Simulink documentation.

The default simulation mode is Normal. In this mode, Simulink software uses
interpreted code, rather than compiled C code during simulations.

In the Accelerator mode, Simulink Parameter Estimation software runs
simulations during estimation with compiled C code. Using compiled C code
speeds up the simulations and reduces the time to estimate parameters.

Limitations
You cannot use the Accelerator mode if your model contains algebraic loops.
If the model contains MATLAB® function blocks, you must either remove
them or replace them with Fcn blocks.

Setting the Accelerator Mode for Parameter
Estimation
To set the simulation mode to Accelerator, open the Simulink model window
and perform one of the following actions:

• Select Simulation > Accelerator.

• Choose Accelerator from the drop-down list as shown in the next figure.

1-56



Accelerating the Estimation

Tip To obtain the maximum performance from the Accelerator mode, close
all Scope blocks in your model.
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Estimating Independent Parameters

In this section...

“Basic Steps for Estimating Independent Parameters” on page 1-58

“Example: Estimating Independent Parameters” on page 1-58

Basic Steps for Estimating Independent Parameters
Sometimes parameters in your model depend on independent parameters that
do not appear in the model. The following steps give an overview of how to
estimate independent parameters:

1 Add the independent parameters to the model workspace (along with
initial values).

2 Define a Simulation Start function that runs before each simulation of the
model. This Simulation Start function defines the relationship between the
dependent parameters in the model and the independent parameters in
the model workspace.

3 The independent parameters now appear in the Select Parameters dialog
box. Add these parameters to the list of parameters to be estimated.

Caution Avoid adding independent parameters together with their
corresponding dependent parameters to the lists of parameters to be
estimated. Otherwise the estimation could give incorrect results. For
example, when a parameter x depends on the parameters a and b, avoid
adding all three parameters to the list.

Example: Estimating Independent Parameters
Assume that the parameter Kint in the model srotut1 is related to the
parameters x and y according to the relationship Kint=x+y. Also assume that
the initial values of x and y are 1 and -0.7 respectively. To estimate x and y
instead of Kint, first define these parameters in the model workspace. To
do this:
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1 At the MATLAB® prompt, type

srotut1

This opens the srotut1 model window.

2 Select View > Model Explorer from the srotut1 window to open the
Model Explorer window.

3 In the Model Hierarchy tree, select the srotut1 > Model Workspace
node.

4 Select Add > MATLAB Variable to add a new variable to the model
workspace. A new variable with a default name Var appears in the
Contents of: Model Workspace pane.

5 Double-click Var to make it editable and change the variable name to x.
Edit the initial Value to 1.

6 Repeat steps 4 and 5 to add a variable y with an initial value of -0.7. The
Model Explorer window should resemble the following figure.
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7 To add the Simulation Start function defining the relationship between
Kint and the independent parameters x and y, select File > Model
Properties in the Simulink® model for srotut1.

8 In the Model Properties window, click the Callbacks tab.

9 To enter a Simulation start function in StartFcn*, type the name of a new
M-file, for example, srotut1_start.

10 Create a new M-file with this name. The contents of the M-file should
define the relationship between the parameters in the model and the
parameters in the workspace. For this example, the M-file should resemble
the following:

wks = get_param(gcs, 'ModelWorkspace')
x = wks.evalin('x')
y = wks.evalin('y')
Kint = x+y;

Note You must first use the get_param function to get the variables x and
y from the model workspace before you can use them to define Kint.

1-60



Estimating Independent Parameters

11 When you select parameters for estimation in the Variables node, x and y
appear in the Select Parameters dialog box.

12 Follow the workflow described in “Setting Up an Estimation Project” on
page 1-23 to estimate the parameters.
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2 Tutorial — Preparing Data for Parameter Estimation Using the GUI

About This Tutorial

In this section...

“Objectives” on page 2-2

“About the Sample Data” on page 2-2

Objectives
In this tutorial, you learn how to import, analyze, and prepare measured
input and output (I/O) data for estimating parameters of a Simulink® model.

Note Simulink® Parameter Estimation™ software estimates parameters
from real, time-domain data only.

You learn to perform the following tasks using the GUI:

• Import data from the MATLAB® workspace.

• Analyze data quality using a time plot.

• Select a subset of data for estimation.

• Remove outliers.

• Filter high-frequency noise.

• Compute missing data using interpolation.

About the Sample Data
In this tutorial, you use spe_engine_throttle1.mat, which contains I/O
data measured from an engine throttle system. The MAT-file includes the
following variables:

• input1 — Input data samples

• position1 — Output data samples

• time1 — Time vector
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Note The number of input and output data samples must be equal to the
length of the corresponding time vector.

The engine throttle system controls the flow of air and fuel mixture to the
engine cylinders. The throttle body contains a butterfly valve which opens
when a driver presses the accelerator pedal. Opening this valve increases the
amount of fuel mixture entering the cylinders, which increases the engine
speed. A DC motor controls the opening angle of the butterfly valve in the
throttle system. The input to the throttle system is the motor current (in
amperes), and the output is the angular position of the butterfly valve (in
degrees).

spe_engine_throttle1.mdl contains the Simulink model of the engine
throttle system. For more information on building models, see “Creating a
Simulink Model” in the Simulink documentation.
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Configuring a Project for Parameter Estimation
To perform parameter estimation, you must first configure a Control and
Estimation Tools Manager project.

1 Open the engine throttle system model by typing the following at the
MATLAB® prompt:

spe_engine_throttle1

This command opens the Simulink® model, and loads the data into the
MATLAB workspace.

Simulink® Model of Engine Throttle System
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2 In the Simulink model window, select Tools > Parameter Estimation.

This action opens a new project named Project - spe_engine_throttle1 in
the Control and Estimation Tools Manager GUI. This project contains the
Estimation Task, as shown in the next figure.
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Importing Data into the GUI

In this section...

“Importing Input Data and Time Vector” on page 2-6

“Importing Output Data and Time Vector” on page 2-11

Importing Input Data and Time Vector
In this portion of the tutorial, you import measured I/O data into the Control
and Estimation Tools Manager GUI. Importing data assigns the data to the
corresponding model input and output signals.

The model input and output signals are designated with the Inport Input
and Outport Position blocks respectively, as shown in the figure Simulink®

Model of Engine Throttle System on page 2-4. These blocks let you import I/O
data into the GUI. To learn more about the blocks, see the Inport and Outport
block reference pages in the Simulink® documentation.

You must have already configured the parameter estimation project, as
described in “Configuring a Project for Parameter Estimation” on page 2-4.

To import input data and time vector into the Control and Estimation Tools
Manager GUI:
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1 In the Control and Estimation Tools Manger GUI, select Transient Data
under the Estimation Task node, and click New.

This action creates a New Data node under the Transient Data node.
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2 Select the New Data node.

3 In the Input Data tab, select the Data cell for Channel - 1, and click
Import.

This action opens the Data Import dialog box.
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4 In the Data Import dialog box, select input1, and click Import.

This action assigns the input data input1 to the model input signal
spe_engine_throttle1/Input.
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5 Select the Time / Ts cell for Channel - 1.

6 In the Data Import dialog box, select time1, and click Import.

This action assigns the time vector to the model input signal
spe_engine_throttle1/Input.

7 In the Data Import dialog box, click Close.
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Importing Output Data and Time Vector
To import output data and time vector into the Control and Estimation Tools
Manager GUI:

1 In the Control and Estimation Tools Manger GUI, select the Output Data
tab of the New Data node.

2 Select the Data cell for Channel - 1, and click Import.

This action opens the Data Import dialog box.
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3 In the Data Import dialog box, select position1, and click Import.

This action assigns the output data position1 to the model output signal
spe_engine_throttle1/Position.
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4 Select the Time / Ts cell for Channel - 1.

5 In the Data Import dialog box, select time1, and click Import.

This action assigns the time vector to the model output signal
spe_engine_throttle1/Position.

6 In Data Import dialog box, click Close.

You have now imported the I/O data into the Control and Estimation Tools
Manager GUI, and assigned the data to the corresponding model signals.
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Analyzing Data
In this portion of the tutorial, you analyze the output data quality by viewing
the data characteristics on a time plot. Based on the analysis, you decide
whether to preprocess the data before estimating parameters. For example, if
the data contains noise, you might want to filter the noise from the system
dynamics before estimating parameters.

You must have already imported the data into the Control and
Estimation Tools Manager GUI, as described in “Importing Data into
the GUI” on page 2-6. If you have not imported the data, you can
instead load the project spe_engine_throttle1_import.mat from
the matlabroot\toolbox\slestim\slestdemos directory by selecting
File > Load in the Control and Estimation Tools Manager GUI.

To plot the output data on a time plot, select the position1(:,1) cell in the
Output Data tab, and click Plot Data.
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This action plots the measured output data position1(:,1), as shown in
the next figure.

The time plot shows the output data in response to a step input, as described
in “About the Sample Data” on page 2-2. The plot shows a rapid decrease
in the response after t = 0.5 s because the system is shut down. To focus
parameter estimation on the time period when the system is active, you select
the data samples between t = 0 s and t = 0.5 s, as described in “Selecting Data
for Estimation” on page 2-16 section of this tutorial.

The spikes in the data indicate outliers, defined as data values that deviate
from the mean by more than three standard deviations. They may be caused
by measurement errors or sensor problems. The response also contains noise.
Before estimating model parameters from this data, you remove the outliers
and filter the noise, as described in “Removing Outliers” on page 2-25, and
“Filtering Data” on page 2-29 sections of this tutorial.

Tip You can also plot the input data on a time plot by selecting the
input1(:,1) cell in the Input Data tab, and clicking Plot Data.
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Selecting Data for Estimation

In this section...

“Selecting Output Data” on page 2-16

“Selecting Input Data” on page 2-22

Selecting Output Data
In this portion of the tutorial, you select a subset of I/O data for estimation.
As described in “Analyzing Data” on page 2-14, the system is shut down at t =
0.5 s. To focus the estimation on the time period before t = 0.5 s, you exclude
the data samples beyond t = 0.5 s. This operation selects the data between
t = 0 s and t = 0.5 s for estimation.

You must have already imported the data into the Control and
Estimation Tools Manager GUI, as described in “Importing Data into
the GUI” on page 2-6. If you have not imported the data, you can
instead load the project spe_engine_throttle1_import.mat from
the matlabroot\toolbox\slestim\slestdemos directory by selecting
File > Load in the Control and Estimation Tools Manager GUI.

To select the portion of data between t = 0 s and t = 0.5 s:

1 In the Control and Estimation Tools Manager window, select the New
Data node under the Transient Data node.
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2 Select the position1(:,1) cell in the Output Data tab, and click
Pre-process.

This action opens the Data Preprocessing Tool GUI.

The Data Editing area of the Data Preprocessing Tool GUI shows the
output data and time vector in the position1(:,1) and Time (seconds)
columns, respectively. The Data Preprocessing Tool GUI lets you perform
the following types of preprocessing operations:

• Excluding data

• Detrending and filtering data

• Handling missing data

3 To exclude the output data beyond t = 0.5 s:

a In the Exclusion Rules tab, select the Bounds check box.
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b In the Exclude X field, where X corresponds to the time vector,
select > from the drop-down list. Enter 0.5 in the adjacent field to specify
the upper limit of the data to select for estimation.

The Data Preprocessing Tool GUI resembles the next figure.

2-18



Selecting Data for Estimation

c Click Add.

This action adds a new Dataset1 node under the Transient Data node
in the Control and Estimation Tools Manager GUI. The Dataset1 node
contains the modified output data position1(:,1)* in the Output
Data tab.
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This operation also replaces the output data samples beyond t = 0.5 s
in position1(:,1)* with NaNs. You can view the NaNs by selecting the
Modified data tab in the Data Preprocessing Tool GUI, as shown in
the next figure.

4 To remove the NaNs:

a In the Control and Estimation Tools Manager GUI, select the Output
Data tab of the Dataset1 node.

b Select the position1(:,1)* cell, and click Pre-process.

This action updates the Data Preprocessing Tool GUI with the selected
data position1(:,1)*.
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c In the Missing Data Handling area, select the

Remove rows where data is excluded or missing check box.

Tip You can view the results of this operation in the Modified data tab.

d In the Write results to area, select the existing dataset
option.

e Click Add.

The Update table data dialog box appears. Click Yes to overwrite the
position1(:,1)* data set with the modified data.
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5 To plot the data, select the position1(:,1)* cell in the Output Data tab
of the Dataset1 node, and click Plot Data.

The selected output data from t = 0 s to t = 0.5 s is shown in the next figure.

Selecting Input Data
After you select the output data between t = 0 s and t = 0.5 s, as described in
“Selecting Output Data” on page 2-16, you must also select the corresponding
input data samples. This operation makes the number of I/O data samples
equal.

1 In the Control and Estimation Tools Manger GUI, select the New Data
node under the Transient Data node.

2 In the Input Data tab, select the input1(:,1) cell, and click Pre-process.

This action updates the Data Preprocessing Tool GUI with the selected
data input1(:,1).
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3 To exclude the data beyond t = 0.5 s:

a In the Exclusion Rules tab, select the Bounds check box.

b In the Exclude X field, where X corresponds to the time vector,
select > from the drop-down list. Enter 0.5 in the adjacent field to specify
the upper limit of the input data to select for estimation.

c In the Write results to area, verify that the

existing dataset option remains selected.

d Click Add.

This action adds the modified data input1(:,1)* to the Input Data
tab of the Dataset1 node. This operation also replaces the input data
samples beyond t = 0.5 s in input1(:,1)* with NaNs.

4 To remove the NaNs:

a In the Control and Estimation Tools Manager GUI, select the
input1(:,1)* cell in the Input Data tab of the Dataset1 node, and
click Pre-process.

This action updates the Data Preprocessing Tool GUI with the selected
data input1(:,1)*.

b In the Missing Data Handling area, select the

Remove rows where data is excluded or missing check box.

c In the Write results to area, verify that the

existing dataset option remains selected.

d Click Add.

The Update table data dialog box appears. Click Yes to overwrite the
input1(:,1)* data set with the modified data.
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5 To plot the data, select the input1(:,1)* cell in the Input Data tab of the
Dataset1 node, and click Plot Data.

The selected input data from t = 0 s to t = 0.5 s is shown in the next figure.
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Removing Outliers

In this section...

“Why Remove Outliers” on page 2-25

“How to Remove Outliers” on page 2-25

Why Remove Outliers
Outliers are data values that deviate from the mean by more than three
standard deviations. When estimating parameters from data containing
outliers, the results may not be accurate.

Removing outliers replaces the data samples containing outliers with NaNs,
which represent missing data. You interpolate the missing data values in a
subsequent operation, as described in “Interpolating Missing Data” on page
2-34.

How to Remove Outliers
In this portion of the tutorial, you remove outliers from the output data. You
must have already selected a subset of the data, as described in “Selecting
Data for Estimation” on page 2-16. If you have not done this preparation,
you can instead load the project spe_engine_throttle1_exclude.mat
from the matlabroot\toolbox\slestim\slestdemos directory by selecting
File > Load in the Control and Estimation Tools Manager GUI.

1 In the Control and Estimation Tools Manger, select the position1(:,1)*
cell in the Output Data tab of the Dataset1 node, and click Pre-process.

This action updates the Data Preprocessing Tool GUI with the selected
data position1(:,1)*.
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2 In the Exclusion Rules tab, select the Outliers check box.

By default, the Window length and Confidence limits fields are set to
10 and 95 respectively. The Window length field specifies the number
of successive data samples the software uses to compute the mean and
standard deviation. The Confidence limits field specifies the threshold
number for identifying outliers. In this example, the mean and standard
deviation of 10 successive data samples are computed, and data values that
exceed 95% of standard deviation are identified as outliers.

Note The data samples containing outliers are replaced with NaNs.

3 In the Write results to area, verify that the existing dataset
option remains selected.
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4 Click Add.

The Update table data dialog box appears. Click Yes to overwrite the
position1(:,1)* data set with the modified data.

5 To plot the data, select the position1(:,1)* cell in the Output Data tab
of the Dataset1 node, and click Plot Data.

The spikes, which indicate outliers, no longer appear on the time plot, as
shown in the next figure.
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The missing data samples, represented by NaNs, appear as gaps on the
time plot. To see an example, zoom in to the bottom-left corner of the plot.
As shown in the next figure, the data values corresponding to t = 0.009 s
and t = 0.019 s are missing.
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Filtering Data

In this section...

“Filtering Output Data” on page 2-29

“Filtering Input Data” on page 2-32

Filtering Output Data
In this portion of the tutorial, you filter the noise, and remove any periodic
trends from the output data. To avoid relative phase shift between the I/O
data, you must also apply the same filter to the input data.

You must have already removed outliers from the output data, as described
in “Removing Outliers” on page 2-25. If you have not done this preparation,
you can instead load the project spe_engine_throttle1_removeoutlier.mat
from the matlabroot\toolbox\slestim\slestdemos directory by selecting
File > Load in the Control and Estimation Tools Manager GUI.

1 In the Control and Estimation Tools Manager window, select the
position1(:,1)* cell in the Output Data tab of the Dataset1 node, and
click Pre-process.

This action updates the Data Preprocessing Tool GUI with the selected
data position1(:,1)*.
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2 In the Detrend/Filtering tab:

a Select the Filtering check box.

By default, First order is selected as the filter type. To learn more
about the filters, see “Filtering” on page 5-15.

b Specify 0.001 in the First order filter with time constant field.

This field specifies the time constant for the first-order filter.

Tip For calculating the time constant, you can visually inspect the time
plot to determine the frequency components.

3 In the Write results to area, verify that the existing dataset
option remains selected.
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4 Click Add.

The Update table data dialog box appears. Click Yes to overwrite the
position1(:,1)* data set with the modified data.

5 To plot the data, select the position1(:,1)* cell in the Output Data tab
of the Dataset1 node, and click Plot Data.

The noise is filtered and the output data appears smooth, as shown in
the next figure.
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Filtering Input Data
After you filter the output data, as described in “Filtering Output Data” on
page 2-29, you must also filter the input data with the same filter.

1 In the Control and Estimation Tools Manager window, select the
input1(:,1)* cell in the Input Data tab of the Dataset1 node, and click
Pre-process.

This action updates the Data Preprocessing Tool GUI with the selected
data input1(:,1)*.

2 In the Detrend/Filtering tab:

a Select the Filtering check box.

By default, First order is selected as the filter type.

b Specify 0.001 in the First order filter with time constant field.

3 In the Write results to area, verify that the existing dataset
option remains selected.

4 Click Add.

The Update table data dialog box appears. Click Yes to overwrite the
input1(:,1)* data set with the modified data.
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5 To plot the data, select the input1(:,1)* cell in the Input Data tab of the
Dataset1 node, and click Plot Data.
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Interpolating Missing Data
In this portion of the tutorial, you interpolate the output data to compute the
missing values created when removing outliers, as described in “Removing
Outliers” on page 2-25. The interpolation operation uses the known data
values to compute the missing data values.

You must have already filtered the noise, as described in “Filtering Data”
on page 2-29. If you have not already done this preparation, you can
instead load the saved project spe_engine_throttle1_filter.mat from
the matlabroot\toolbox\slestim\slestdemos directory by selecting
File > Load in the Control and Estimation Tools Manager GUI.

1 In the Control and Estimation Tools Manager GUI, select the
position1(:,1)* cell in the Output Data tab of the Dataset1 node, and
click Pre-process.

This action updates the Data Preprocessing Tool GUI with the selected
data position1(:,1)*.
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2 In the Missing Data Handling area, select the Interpolate missing
values using interpolation method check box.

By default, zoh is selected as the interpolation method. This method fills
the missing data sample with the data value immediately preceding it.

Tip You can view the interpolated data samples in the Modified data tab.

3 In the Write results to area, verify that the existing dataset
option remains selected.

4 Click Add.

The Update table data dialog box appears. Click Yes to overwrite the
position1(:,1)* data set with the modified data.
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5 To plot the data, select the position1(:,1)* cell in the Output Data tab
of the Dataset1 node, and click Plot Data.

The new estimation data, prepared by removing outliers, filtering noise,
and interpolating missing data, is shown the next figure.
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Saving the Project
After you prepare the data, you can delete the data in the New Data
node, rename the prepared data, and save the session. To skip the data
preparation steps, load the project spe_engine_throttle1_interpolate.mat
from the matlabroot\toolbox\slestim\slestdemos directory by selecting
File > Load in the Controls and Estimation Tools Manager GUI.

1 In the Control and Estimation Tools Manger GUI, select the New Data
node under the Transient Data node.

2 Right-click the New Data node, and select Delete.

3 Select the Dataset1 node under the Transient Data node.
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4 Right-click the Dataset1 node, and select Rename. Specify
Estim_Data_Prep as the name of the new estimation data set.

The Control and Estimation Tools Manager GUI resembles the next figure.
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5 Save the Control and Estimation Tools Manager project:

a In the Control and Estimation Tools Manager GUI, select File > Save.

This action opens the Save Projects dialog box.

b In the Save Projects dialog box, click OK.

c In the Save Projects window, specify spe_engine_throttle1p.mat in
the File name field, and click Save.

The action saves the project as a MAT-file.

To learn how to estimate parameters from this data, see Chapter 3, “Tutorial
— Estimating Parameters from Measured Data Using the GUI”.
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About This Tutorial

In this section...

“Objectives” on page 3-2

“About the Model ” on page 3-3

Objectives
In this tutorial, you learn how to estimate parameters of a single-input
single-output (SISO) Simulink® model from measured input and output (I/O)
data.

Note Simulink® Parameter Estimation™ software estimates parameters
from real, time-domain data only.

You learn to perform the following tasks using the GUI:

• Load a saved project containing data.

• Estimate model parameters using default settings.

• Validate the model, and refine the estimation results.
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About the Model
In this tutorial, you use the spe_engine_throttle1 Simulink model. This
model represents an engine throttle system, as shown in the next figure.

The throttle system controls the flow of air and fuel mixture to the engine
cylinders. The throttle body contains a butterfly valve which opens when a
driver presses the accelerator pedal. Opening this valve increases the amount
of fuel mixture entering the cylinders, which increases the engine speed. A
DC motor controls the opening angle of the butterfly valve in the throttle
system. The models for these components are described in “Motor Subsystem”
on page 3-4, and “Throttle Subsystem” on page 3-5.

The input to the throttle system is the motor current (in amperes), and the
output is the angular position of the butterfly valve (in degrees).
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Motor Subsystem
The Motor subsystem contains the DC motor model. To open the model,
double-click the corresponding block.

The following table describes the variables, parameters, equation, input, and
output of the Motor subsystem.

Variables U is the input current to the motor.

T is the torque applied by the motor.

Parameters Kt is the torque gain of the motor, represented by Kt in the
model.

td is the input time delay of the motor, represented by
input_delay in the model.

Equation The torque applied by the motor is described in the
following equation:

T t K U t tt d( ) ( )= −

where t is time.

Input U

Output T
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Throttle Subsystem
The Throttle subsystem contains the butterfly valve model. To open the
model, right-click the corresponding block, and select Look Under Mask.

The Hard Stops block models the valve angular position limit of 15° to 90°.

The following table describes the variables, parameters, states, differential
equations, inputs, and outputs of the Throttle subsystem.

Variables T is the torque applied by the DC motor.

θ is the angular position of the valve, represented
by x in the model.

Thardstop is the torque applied by the hard stop.

Parameters J is the inertia.

c is the viscous friction.

k is the spring constant.

States θ is the angular position.

�θ is the angular velocity.
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Equations The mathematical system for the butterfly valve
is described in the following equation:

J c k T Thardstop
�� �θ θ θ+ + = +

where 15 90� �≤ ≤θ , with initial conditions

θ0 15= � , and �θ0 0= .The torque applied by the
Hard Stops block is described in the following
equation:
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where K is the gain of the Hard Stops block.

Input T

Output θ
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Estimating Model Parameters Using Default Estimation
Settings

In this section...

“Overview of the Estimation Process” on page 3-7

“Specifying Parameters and Estimation Data” on page 3-8

“Validating Model Parameters” on page 3-13

Overview of the Estimation Process
Simulink® Parameter Estimation™ software uses optimization techniques
to estimate model parameters. In each optimization iteration, the model
is simulated with the current parameter values. The error between the
simulated and measured output is computed and minimized. The estimation
is complete when the optimization algorithm finds a local minimum.

You perform the following tasks to estimate the model parameters:

• “Specifying Parameters and Estimation Data” on page 3-8

• “Validating Model Parameters” on page 3-13
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Specifying Parameters and Estimation Data
To specify parameters and estimation data:

1 Load the saved project spe_engine_throttle1p.mat.

This MAT-file contains the estimation data. To learn more about the data
and how to prepare it, see Chapter 2, “Tutorial — Preparing Data for
Parameter Estimation Using the GUI”.

a Open the engine throttle system Simulink® model by typing the following
at the MATLAB® prompt:

spe_engine_throttle1

b In the Simulink model window, select Tools > Parameter Estimation.

This action opens a new project named Project - spe_engine_throttle1
in the Control and Estimation Tools Manager GUI.

c In the Control and Estimation Tools Manager GUI, select File > Load.
Browse to the matlabroot\toolbox\slestim\slestdemos directory, and
select spe_engine_throttle1p.mat.

The Confirm Node Replace dialog box appears. Click Yes to load the
project into the Control and Estimation Tools Manager GUI.
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When you expand the Estimation Task node, the Controls and Estimation
Tools Manager GUI resembles the next figure.
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2 Specify parameters for estimation.

a Select the Variables node under the Estimation Task node.

b Click Add.

This action opens the Select Parameters dialog box, which shows the
model parameters for the Simulink model.

c Select the parameters J, c, input_delay, and k by pressing the Ctrl key
while clicking each name, and then click OK.

This action adds the selected parameters to the Estimated Parameters
tab.
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Tip When estimating a large number of parameters, you can select
a subset of parameters to estimate. To learn more, see the Inverted
Pendulum Parameter Estimation demo in the Demos pane in the
MATLAB Help browser.

d Select the Estimation node, and click New.

This action adds a New Estimation node under the Estimation node.

e Select the New Estimation node.
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f In the Parameters tab, select the Estimate check box for all the
parameters.

This action specifies the selected parameters for estimation.

The Parameters tab, as shown in the previous figure, displays the
following information for each parameter:

• Value: Current parameter value. By default, it is equal to the value
specified in the Simulink model.

During estimation, the optimization algorithm might change a
parameter value to minimize the error between the measured and
simulated output.

• Initial Guess: Initial parameter value. By default, it is equal to the
value in the Value field and is used at the start of estimation.
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• Minimum and Maximum: Bounds on the parameter value. By
default, they are set to -Inf, and +Inf, respectively. This means
that the optimization algorithm searches for a solution in the range
[-Inf, +Inf].

• Typical Value: Order of magnitude of the parameter value. By
default, it is equal to the value in the Initial Guess field.

3 Specify data for estimation by checking the Selected check box for
Estim_Data_Prep in the Data Sets tab.

Validating Model Parameters
After you specify parameters and data for estimation, as described in
“Specifying Parameters and Estimation Data” on page 3-8, estimate the
parameters and analyze the results to determine if the model needs to be
refined.
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1 Create plots to view the estimation results.

a Select the Views node under the Estimation node, and click New.

This action creates a New View node under the Views node.

b Select the New View node.

c In the View Setup tab, select the following plots from the drop-down
list in the Plot Type column:

• For Plot 1, select Measured and simulated.

• For Plot 2, select Cost function.
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d In the Options area, select the Plot 1 and Plot 2 check boxes, and click
Show Plots.

Clicking Show Plots opens the following figures:

• New View - Plot 1 (Measured and simulated): Displays the
measured output data Estim_Prep_Data. During estimation, this plot
updates to display the simulated response at each iteration.

• New View - Plot 2 (Cost function): Displays the error between
the measured and simulated output, computed at each iteration. By
default, the error is computed using sum- of- squared- errors, which is
a least-squares method.

2 Estimate the parameters by selecting the Estimation tab of the New
Estimation node, and clicking Start.
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The Estimation tab updates at each iteration, and provides information
about the estimation progress. When the estimation completes, the
Estimation tab resembles the next figure.

Note The results of the optimization may differ slightly because of
different numerical precision across platforms.

The table displays the following information for each iteration:

• Cost Function: Error between the simulated and measured output.

During estimation, the default optimization algorithm Nonlinear
least squares, lsqnonlin, minimizes the cost function by changing the
parameter values. As shown in the previous figure, the cost function
decreases by only 27% from 2.69e5 to 1.95e5.
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• Step Size: Displacement of the optimization algorithm in the current
search direction when minimizing the cost function. A final value close to
zero indicates that the algorithm has found a local minimum. As shown
in the previous figure, the final step size in the last iteration is 5.96e-7.

3 View the estimated parameter values in the Value column of the
Parameters tab.
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4 Examine the simulated response plot to see how well the simulated output
matches the measured output.

The simulated response with the estimated parameters is shown in
blue on the New View - Plot 1 (Measured and simulated) plot, and
significantly differs from the measured data. This difference indicates that
the estimated parameters are not accurate.
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5 Examine the cost function plot to see how the cost function changes during
the estimation.

The cost function values shown in step 2 are plotted on the New View -
Plot 2(Cost function) plot. The cost function decreases by only 27%
from its initial value, and in conjunction with the measured and simulated
output plot, indicates that the estimated parameters are not accurate.

To improve the estimation results, you apply bounds on the parameter values,
as described in “Improving Estimation Results Using Parameter Bounds”
on page 3-20.
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Improving Estimation Results Using Parameter Bounds

In this section...

“Strategy for Improving the Estimation Results” on page 3-20

“How to Specify Parameter Bounds” on page 3-20

Strategy for Improving the Estimation Results
Analyzing the Measured and Simulated and Cost function plots, as
described in “Validating Model Parameters” on page 3-13, you see that the
model parameters estimated using the default estimation settings are not
accurate. You must run additional estimations to improve the accuracy of the
model. There are several techniques to improve the accuracy of the estimated
parameters. For more information, see “Tuning the Results of Optimization”
on page 1-46.

In this portion of the tutorial, you improve the results by specifying bounds
on parameter values. This technique restricts the region in which the
optimization algorithm searches for a local minima.

Based on physical insight, you know the following characteristics of the
engine throttle system:

• All the parameter values are positive.

• Maximum time delay of the system, represented by input_delay, is 0.1 s.

Therefore, you specify 0 as the minimum value for all parameters, and 0.1 as
the maximum value of input_delay.

After you estimate the parameters, analyze the results using the Measured
and Simulated and Cost function plots.

How to Specify Parameter Bounds
You must have already estimated the parameters using default settings,
as described in “Estimating Model Parameters Using Default Estimation
Settings” on page 3-7.
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To improve the estimation results by specifying parameter bounds:

1 Select the Parameters tab of the New Estimation node.

2 Specify the minimum value for each parameter by double-clicking the
corresponding Minimum cell, and replacing -Inf with 0.

3 Specify the maximum value for input_delay by double-clicking the
corresponding Maximum cell and replacing +Inf with 0.1.

The Parameters tab resembles the next figure.
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4 Select the Estimation tab, and click Start.

The Estimation tab updates at each iteration, and provides information
about the estimation progress. When the estimation completes, the
Estimation tab resembles the next figure.

Note The results of the optimization may differ slightly because of
different numerical precision across platforms.

The cost function decreases by 99% from 1.95e5 to 239.94. The final step
size 8.75e-7 is close to 0, which indicates that the optimization algorithm
has found a local minimum.

3-22



Improving Estimation Results Using Parameter Bounds

5 View the estimated parameter values in the Value column of the
Parameters tab.
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6 Examine the simulated response plot to see how well the simulated output
matches the measured output.

The simulated response plot, shown in blue on the New View - Plot 1
(Measured and simulated) plot, is overlaid on the measured output data.
The simulated output closely matches the measured data.
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7 Examine the cost function plot to see how the cost function changes during
the estimation.

The cost function values shown in step 4 are plotted on the New View
- Plot 2(Cost function) plot. The cost function also decreases by
99% from its initial value, and in conjunction with the measured and
simulated response plot indicates a good fit of the simulated response with
the measured data.
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Validating Estimated Model Parameters
After you estimate the model parameters, as described in “Improving
Estimation Results Using Parameter Bounds” on page 3-20, validate the
model using another data set (validation data). A good match between the
simulated response and the validation data indicates that you have not
overfitted the model.

To validate the estimated parameters using a validation data set:

1 Load the project spe_engine_throttle1_importValData1.mat from
the matlabroot\toolbox\slestim\slestdemos directory by selecting
File > Load in the Control and Estimation Tools Manager GUI.

The MAT-file contains a validation data set already imported into the GUI,
and the estimated parameters as described in “Improving Estimation
Results Using Parameter Bounds” on page 3-20. The validation data
contains the input data, output data and time vector in the MATLAB
variables input2, position2 and time2 respectively.

Tip To learn how to import data and time vector into the Control and
Estimation Tools Manager GUI, see “Importing Data into the GUI” on
page 2-6.

When you expand the Estimation Task node, the Control and Estimation
Tools Manager GUI resembles the next figure.
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2 Plot the measured and simulated response, and residuals.

a Select the Validation node, and click New.

This action creates a New Validation node.

b Select the New Validation node.

c In the Validation Setup tab, select the following plots in the Plot Type
column.

• For Plot 1, select Measured and simulated.

• For Plot 2, select Residuals.

d In the Options area, select the Plot 1, and Plot 2 check boxes.

e Select Validation Data 1 from the Validation data set drop-down list.

The Validation Setup tab resembles the next figure.
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f Click Show Plots.

This action opens the following figures:

• New Validation - Plot 1 (Measured and simulated): Displays
the validation data and simulated response.

• New Validation - Plot 2(Residuals): Displays the difference
between the measured data and simulated response.

3 Examine the simulated response plot to see how well the simulated output
matches the validation data..

The simulated response, as shown in blue on the New Validation - Plot
1 (Measured and simulated) plot, is overlaid on the measured output
data, and closely matches the measured data Validation Data 1.
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4 Examine the residuals plot to compare the difference between the
simulated response and measured data.

The difference between the simulated and measured data, as shown in the
New Validation - Plot 2(Residuals) plot, varies between 2 and -2.5.
The residuals lie within 6% of the maximum output variation, and do not
display any systematic patterns. This indicates a good fit between the
simulated output and measured data.

3-29



3 Tutorial — Estimating Parameters from Measured Data Using the GUI

5 Save the Control and Estimation Tools Manager project.

a In the Control and Estimation Tools Manager GUI, select File > Save.

This action opens the Save Projects dialog box.

b In the Save Projects dialog box, click OK.

c In the Save Projects window, specify the name of the project in the File
name field, and click Save.

This action saves the project as a MAT-file.
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Tip You can load a project by selecting File > Load in the Control and
Estimation Tools Manager GUI. To view the estimated parameter values,
select the Parameters tab of New Estimation node.
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4 Estimating Initial Conditions

Why Estimate Initial Conditions?
Often, sets of measured data are collected at various times and under
different initial conditions. When you estimate model parameters using one
data set and subsequently run another estimation with a second data set,
your parameter values may not match. Given that the Simulink® Parameter
Estimation™ software attempts to find constant values for parameters, this
is clearly a problem.

You can estimate the initial conditions using procedures that are similar to
those you use to estimate parameters. You can then use these initial condition
estimates as a basis for estimating parameters for your Simulink® model. The
Control and Estimation Tools Manager has an Estimated States pane that
lists the states available for initial condition estimation.

This chapter focuses on the steps required to estimate initial conditions, and
then estimate the parameters from these initial conditions.
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Estimating Initial Conditions for Blocks with External
Initial Conditions

When an integrator block uses an initial-condition port, which you specify by
an IC block feeding into the integrator block, you cannot estimate the initial
conditions (ICs) of the integrator using Simulink® Parameter Estimation™
software. This is because external ICs have priority over the ICs of a specific
block to maintain the integrity of the model.

To tune the ICs of an integrator block with external ICs, you must modify the
model to make the external signal into a tunable parameter. For example, you
can set the IC block that feeds into the integrator to be a tunable variable
and estimate it.
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Example: Mass-Spring-Damper System

In this section...

“Loading the Example” on page 4-4

“Model Parameters” on page 4-5

“Setting Up the Estimation Project” on page 4-6

“Importing Transient Data and Selecting Parameters for Estimation” on
page 4-7

“Selecting Parameters and Initial Conditions for Estimation” on page 4-8

“Creating the Estimation Task” on page 4-10

“Running the Estimation and Viewing Results” on page 4-11

Loading the Example
To open the Simulink® model of a mass-spring-damper system and two sets of
model data with differing initial conditions, type:

msd_system

at the MATLAB® prompt.

The figure shown next is a model of a mass-spring-damper system.
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You can run the demo from Simulink > Simulink Parameter Estimation
on the Demo pane of the Help browser.

This example goes beyond what is included in the Simulink® Parameter
Estimation™ demo that uses this model by providing in-depth discussion
of each task.

Model Parameters
The Simulink msd_system model’s output is the displacement (or position)
of the mass in a mass-spring-damper system, subject to a constant force F,
and an initial condition, x0, for the mass displacement. x0 is indicated by the
initial condition of the Position integrator block. Click the Start Simulation
button to run the simulation once and observe the response of the model to
two sets of parameter values.
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The model parameters of interest are the mass, m, the viscous damping, b,
and the spring constant, k. For more information about physical modeling
of mass-spring-damper systems, see any elementary book on mathematical
modeling or on automatic control systems.

For the estimation of the model parameters m, b, and k, this model uses two
sets of experimental data. These data sets were obtained using two different
initial positions, x0=0.1 and x0=0.3, and also contain additive noise. A plot
of these data sets is shown in the figure above (top curves), along with the
simulated response (bottom curve) of the Simulink model msd_system for
x0=-0.1 and a nominal set of parameter values, m=8, k=500, and b=100.

Setting Up the Estimation Project
To set up the estimation of initial conditions and then transient state space
data, select Tools > Parameter Estimation in the msd_system model
window.
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Importing Transient Data and Selecting Parameters
for Estimation
The process for importing transient data and selecting parameters for
estimation is discussed in “Importing Transient Data” on page 1-11 and
“Selecting Parameters for Estimation” on page 1-17.

1 In the Control and Estimation Tools Manager, select Estimation Task
> Transient Data in the workspace directory tree.

2 Right-click Transient Data and select New to add a new data set.

3 Right-click the New Data node in the workspace directory tree and select
Edit to open the Input Data, Output Data, and State Data panes.

4 In the Output Data pane, click Import and add yexp1 to the Data column
and texp1 to the Time/Ts column of the msd_system/Position state.
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5 If you like, right-click New Data in the workspace directory tree and
rename it to Data set #1.

6 Repeat steps 1 to 5 to add a second data set, yexp2 and texp2, and rename
it to Data set #2.

Your Control and Estimation Tools Manager should resemble this figure:

Selecting Parameters and Initial Conditions for
Estimation
First, select the parameters you want to estimate for the Simulink msd_system
model. In this case, select b, k, and m. To do this:

1 Select the Variables node in the workspace directory tree of the Control
and Estimation Tools Manager.

2 Click the Estimation Parameters tab.
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3 Click Add to open the Select Parameters dialog box.

4 Select the parameters b, k, and m, and then click OK.

5 Do the same with the Estimation States pane, and select
msd_system/Position from the Select States dialog box.
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Your Control and Estimation Tools Manager should look like this.

Creating the Estimation Task
To create the New Estimation task in the Control and Estimation Tools
Manager, right-click the Estimation node in the workspace directory tree
and select Add. While the initial velocity is also a state of the model, assume
(for simplicity) that it is known to be 0. The estimation task for this case
is Estim (with IC).

In the Data Sets, Parameters, and States panes for the New Estimation
task, select all the check boxes in each table. Be sure to select Position for
both data sets in the States pane to estimate the initial condition for the
spring’s position.

The initial position estimates for the two data sets are known to differ, but set
the initial state guesses for both data sets to -0.1.
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Running the Estimation and Viewing Results
Click Start in the Estimation pane to run the estimation. As the estimation
proceeds, the most current estimation of position response (yellow curve)
updates itself in the Scope. The curve appears to toggle between the two
experimental data sets, since the estimator uses the two sets successively to
update the estimates of the parameter values. The estimator converges to
the correct parameter values, within the scope of experimental noise and
optimization options settings, as indicated by the closeness of the estimated
response (yellow) to the experimental data (magenta). Good state estimates
for the initial position are also obtained, as can be observed from the States
tab of Estim(with IC) estimation task.
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The estimation of initial states is important for obtaining the correct estimates
of the model parameters. Why not set the initial states (x0 in this case) as
parameters as well? The reason is that the initial states are not fixed physical
properties of the system. For different experimental data or operating
conditions, these states need not be unique. In this example, two data sets,
with distinct initial positions, were used together for a single estimation of
model parameters. While the estimates of the model parameters are unique,
the initial state (position) is different, and is estimated individually for each
data set.
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5 Preprocessing Data

Why Preprocess Data?
When dealing with empirical data, it is often useful to remove outliers,
smooth, detrend, or otherwise treat the data to make it more tractable for
analysis and estimation purposes. You can perform the following tasks using
Simulink® Parameter Estimation™ software:

• Exclusion — Eliminate outliers, represent them as NaNs, or use
interpolation.

• Detrending — Remove mean values or a straight line trend.

• Filter — Smooth data using a first-order filter, an arbitrary transfer
function, or an ideal filter.

You can overwrite the existing data with the preprocessed data, or store it
in a new file.
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Data Preprocessing Tool
You can preprocess your data using the Data Preprocessing Tool. To open it:

1 Open the Control and Estimation Tools Manager.

2 In the workspace directory tree, expand the Estimation Task node.

3 Select the Transient Data node in the workspace directory tree, and then
choose the data you want to modify in the Input Data, or Output Data
pane. This enables the Pre-process button.

4 Click the Pre-process button to open the Data Preprocessing Tool.
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In this chapter, the sample data set is the same as used in the
engine_idle_speed Simulink® model. See “How Simulink® Parameter
Estimation™ Software Works” on page 1-6 for an overview of creating
estimation projects and adding data sets.

With the Data Preprocessing Tool, you can

• Exclude data by selecting it with your mouse.

• Exclude data graphically by selecting regions on a plot.

• Exclude data by rules, such as upper or lower bounds.

• Detrend data.

• Filter data.
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Excluding Data

Excluding Data

In this section...

“Techniques for Excluding Data in the Data Preprocessing Tool” on page 5-5

“Selecting Data for Exclusion from the Data Editing Table” on page 5-5

“Selecting Data for Exclusion from a Plot of the Data” on page 5-8

“Selecting Data for Exclusion by a Rule” on page 5-11

Techniques for Excluding Data in the Data
Preprocessing Tool
You can use the Data Preprocessing Tool to select a portion of the data to be
excluded from the estimation process. You can choose one of the following
techniques:

• Selecting data from the Data Editing Table.

• Selecting data from a plot of the Data.

• Specifying a Rule.

You accomplish the first two manually, and for the last you specify a rule.
When you exclude data using manual selection, the excluded data is shown
as red. When you exclude data using a rule, the background color of the cell
becomes gray. When a portion of the data is excluded both manually and by a
rule, the data is red, and the background is gray.

Note Changes in data are visible everywhere. When you use the Data
Editing table, you can view the results in the data plot.

Selecting Data for Exclusion from the Data Editing
Table
The Data Editing table lists both the raw data set and the modified data
that you create.
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There are two tabs in the Data Editing pane: Raw data and Modified
data. The Raw Data pane shows the working copy of the data. For example,
if you exclude rows of data in the Raw data pane, the corresponding rows
of numbers become red in this table. By default the Modified data pane
represents the rows you removed by inserting NaNs.
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In the Modified data pane, you can choose to remove the excluded data
completely or interpolate it. See “Miscellaneous Data Handling” on page
5-16 for more information.

After you select data for exclusion, you can view it graphically by clicking
Exclude Graphically.
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As you make changes in the Data Editing pane, they immediately appear in
the Select Points for Preprocessing Rule window, and vice versa.

Selecting Data for Exclusion from a Plot of the Data
You can exclude data graphically. Click Exclude Graphically to open the
Select Points for Preprocessing Rule window.
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The way you exclude data is similar to the way you select a region for
zooming: place your cursor in the Input Data plot and drag the mouse to
draw a region of exclusion.

This figure shows an example of resulting data exclusion in the input data.
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In the Output Data plot, the excluded input data produces a blank area by
default. This corresponds to the NaNs that now represent excluded data. If
you choose to interpolate or remove the excluded data, the output data shows
the interpolated points.

When you make changes in the Select Points for Preprocessing Rule window,
they immediately appear in the Data Editing pane, and vice versa.

Selection Pane
By default, any box that you draw with your mouse selects data for exclusion,
but you can toggle between exclusion and inclusion using the Selection pane
on the left side of the Select Points for Preprocessing Rule window.
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Selecting Data for Exclusion by a Rule
A more precise way to exclude data is to use mathematical rules. The
Exclusion Rules pane in the Data Preprocessing Tool allows you to enter
customized rules for excluding data.

These are the rules you can use to exclude data:

• “Upper and Lower Bounds” on page 5-12

• “Outliers” on page 5-12
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• “MATLAB® Expressions” on page 5-12

• “Flatlines” on page 5-12

Upper and Lower Bounds
Select the Bounds check box to activate upper and lower bound exclusion.
Enter numbers in the Exclude X and Exclude Y fields for upper and lower
bound exclusion. By default, the exclusion rule is to include the boundary
values, but you can use the menu to exclude the boundaries as well.

Outliers
Select the Outliers check box to activate outlier exclusion. You can set the
Window length to any positive integer, and use confidence limits from 0 to
100%. The window length specifies the number of data points used when
calculating outliers.

MATLAB® Expressions
Use the MATLAB expression field to enter any mathematical expression
using MATLAB® code. Use x as the variable name in your expression for
the data being tested.

Flatlines
If you have areas of your data set where the data is constant, providing no
new information, then you can choose to exclude those data points as flatlines.
The Window length field sets the minimum number of constant data points
required to define the area as a flatline.
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Example of Rule Exclusion
This figure shows data with a region of the x-axis excluded.
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Detrending and Filtering

In this section...

“Detrending and Filtering Data in the Data Preprocessing Tool” on page
5-14

“Detrending” on page 5-14

“Filtering” on page 5-15

Detrending and Filtering Data in the Data
Preprocessing Tool
You can both detrend and filter data using the Detrend/Filtering pane in
the Data Preprocessing Tool.

Detrending
To detrend, select the Detrending check box. You can choose constant or
straight line detrending. Constant detrending removes the mean of the data
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to create zero-mean data. Straight line detrending finds linear trends (in the
least-squares sense) and then removes them.

Filtering
You have these choices for filtering your data:

• First order — A filter of the type
1

1τs +
where τ is the time constant that you specify in the associated field.

• Transfer function — A filter of the type
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+ + +
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−

1
1

0

1
1

0

…

…

where you specify the coefficients as vectors in the associated A
coefficients and B coefficients fields.

• Ideal — An idealized (noncausal) filter, either stop or pass band. Specify
either filter as a two-element vector in the Range (Hz) field. These filters
are ideal in the sense that there is no finite rolloff or ripple; the ends of the
ranges are perfectly horizontal in the frequency domain.
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Miscellaneous Data Handling

In this section...

“Handling Missing Data” on page 5-16

“Loading Data and Saving Modified Data Sets” on page 5-16

Handling Missing Data
You can use the Missing Data Handling pane at the bottom of the Data
Preprocessing Tool to remove rows of data, or to interpolate between points
to fill in missing data.

Removing Rows
If you select the Remove rows where check box, the affected rows are
removed from the Modified data pane. If you have multiple columns of
data, select all to remove rows in which all the data is excluded. Select any
to remove any excluded cell. In the case of one-column data, any and all
are equivalent.

Interpolation
You have two choices if you want to interpolate data: zero-order hold (zoh)
and linear interpolation (Linear). Select the Interpolate missing values
using interpolation method check box and choose which method you want
from the list. The results appear in the Modified data pane.

Loading Data and Saving Modified Data Sets
At the top of the Data Preprocessing Tool, there is a region for selecting data
sets for preprocessing, and for saving modified data sets.
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When you have multiple data sets, select the one you want to preprocess from
the Modify data from list.

To overwrite an existing data set, select the existing dataset option and
choose the data set you want to overwrite. If you want to save the data
set under a new name, select new dataset and type the new name in the
associated field.
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Multiple Projects and Tasks
The Control and Estimation Tools Manager works seamlessly with products
in the Controls and Estimation family. In particular, if you have licenses for
Simulink® Control Design™ or Model Predictive Control Toolbox™ software,
you can use these products to perform tasks on projects that you have created
in Simulink® Parameter Estimation™ software, and vice versa.

This figure shows a tools manager with multiple projects and multiple tasks.

You can save projects individually, or group multiple projects together in one
saved file. This chapter describes how to do this.
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Saving Control and Estimation Tools Manager Projects
A Control and Estimation Tools Manager project can consist of tasks
from products such as Simulink® Control Design™, Simulink® Parameter
Estimation™, and Model Predictive Control Toolbox™ software. Each task
contains data, objects, and results for the analysis of a particular model.

To save your project as a MAT-file, select File > Save in the Control and
Estimation Tools Manager window.

To save multiple projects within one file:

1 In the Save Projects dialog box, select the projects that you want to save.

2 Click OK.

3 Choose a directory and name for your project file by either browsing for a
file or typing the full path and filename in the Save as field. Click Save.
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Opening Control and Estimation Tools Manager Projects
To open previously saved projects, select File > Load in the Control and
Estimation Tools Manager window.

In the Load Projects dialog box, choose a project file by either browsing for
the directory and file, or by typing the full path and filename in the Load
from field. Project files are always MAT-files. The projects within this file
appear in the Projects list.

Select the projects that you want to load, then click OK. When a file contains
multiple projects, you can choose to load them all or just a few.
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What Are Lookup Tables?
Lookup tables are used to store numeric data in a multidimensional array
format. In the simpler two-dimensional case, lookup tables can be represented
by matrices. Each element of a matrix is a numerical quantity, which can be
precisely located in terms of two indexing variables. At higher dimensions,
lookup tables can be represented by multidimensional matrices, whose
elements are described in terms of a corresponding number of indexing
variables.

Lookup tables provide a means to capture the dynamic behavior of a physical
(mechanical, electronic, software) system. The behavior of a system with
M inputs and N outputs can be approximately described by using N lookup
tables, each consisting of an array with M dimensions.

Lookup tables are usually generated by experimentally collecting or
artificially creating the input and output data of a system. In general, as
many indexing parameters are required as the number of input variables.
Each indexing parameter may take a value within a predetermined set of
data points, which are called the breakpoints. The set of all breakpoints
corresponding to an indexing variable is called a grid. So, a system with
M inputs is girded by M sets of breakpoints. Given the input data, the
breakpoints are then used to locate the array elements, where the output data
of the system are stored. For a system with N outputs, N array elements are
located and the corresponding data are stored at these locations.

Once a lookup table is created using the input and output measurements as
described previously, the corresponding multidimensional array of values
can be used in applications without the need of remeasuring the system
outputs. In fact, only the input data is required to locate the appropriate
array elements in the lookup table and the approximate system output can
be read from the data stored at these locations. Therefore, a lookup table
provides a suitable means of capturing the input-output mapping of a static
system in the form of numeric data stored at predetermined array locations.
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How Adaptive Lookup Tables Work
The generation of lookup tables as described previously, establishes a
permanent and static mapping of input-output behavior of a physical system.
Statically defined lookup tables cannot accommodate the time-varying
behavior (characteristics) of a physical plant. On the other hand, it is well
known that the behavior of actual physical systems often vary with time due
to wear, environmental conditions, and manufacturing tolerances. Under such
variations, the static mapping of input-output behavior of a plant described
by the lookup table may no longer provide a valid representation of the plant
characteristics.

Adaptive lookup tables, on the other hand, incorporate the time-varying
behavior of physical plants into the lookup table generation and maintenance
process while providing all of the functionality of a regular lookup table.

The adaptive lookup table receives the input and output measurements of a
plant’s behavior, which are then used to dynamically create and update the
content of the underlying lookup table. In addition to requiring the input data
to create the lookup table, the adaptive lookup table also uses the output
data of the plant to recalculate the table values. As an example, the output
data of the plant can be collected by placing sensors at appropriate locations
in a physical system.

The input measurements are used to locate the array elements by comparing
these input values with the breakpoints defined for each indexing variable.
Next, the output measurements are used to recalculate the numeric value
stored at these array locations. However, unlike a regular table, which only
stores the array data before the actual use of the lookup table, the adaptive
table continuously improves the content of the lookup table. This continuous
improvement of the table data is referred to as the adaptation or learning
process.

The adaptation process involves statistical and signal processing algorithms
to recapture the input-output behavior of the plant. The adaptive lookup
table always tries to provide a valid representation of the plant dynamics
even though the plant behavior may be time varying. The underlying signal
processing algorithms are also robust against reasonable measurement noise
and they provide appropriate filtering of noisy output measurements.
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Implementation of Adaptive Lookup Tables

In this section...

“Simulink® Blocks for Adaptive Lookup Tables” on page 7-4

“Adaptive Lookup Table Library” on page 7-5

“Using Adaptive Lookup Tables in Simulink® Models” on page 7-6

“Real-Time Lookup Tables” on page 7-6

“Setting Adaptive Lookup Table Parameters” on page 7-7

“Selecting an Adaptation Method” on page 7-8

Simulink® Blocks for Adaptive Lookup Tables
The MathWorks™ implements Adaptive Lookup Tables as Simulink® blocks.
These blocks create multidimensional lookup tables from measured or
simulated data. The inputs and outputs of a n-D Adaptive Lookup Table
block with two inputs are shown next.

Adaptive Lookup Table Block Showing Inputs and Outputs

The following are descriptions of the input and output parameters:

• The inputs u and y are the coordinate data and system output
measurements, respectively. For example, if you want to create a lookup
table to model the behavior of an engine’s efficiency as a function of engine
rpm and manifold pressure, u = [rpm, pressure] and y = [efficiency].
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• The initial table data may be entered either as a dialog box parameter
(by double-clicking the block) or as an input port (i.e., the input port Tin
in the figure). You can start, stop, and reset the adaptation through the
Enable input port.

• The outputs of the block include the value of the currently adapted table
cell (Y), the number (N) of that cell (which may be specified through the
block dialog box), and if required, the whole adapted table data (Tout).

Adaptive Lookup Table Library
Three adaptive lookup tables are available in Simulink® Parameter
Estimation™ software. To access the Adaptive Lookup Tables library, type
the following command at the MATLAB® prompt:

spelookup

The three blocks are

• Adaptive Lookup Table (1D Stair-Fit) — One-dimensional adaptive lookup

• Adaptive Lookup Table (2D Stair-Fit) — Two-dimensional adaptive lookup

• Adaptive Lookup Table (nD Stair-Fit) — Multidimensional adaptive lookup
(use this for dimension 3 or higher)
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Using Adaptive Lookup Tables in Simulink® Models
A typical Simulink diagram using an adaptive lookup table block is shown
next.

Simulink® Diagram Using an Adaptive Lookup Table

In this figure, the Experiment Data block imports a set of experimental data
into Simulink through MATLAB workspace variables. The initial table is
specified through a constant matrix block. When the simulation runs, the
initial table begins to adapt to new data inputs and the resulting table is
copied to the block’s output.

Real-Time Lookup Tables
You can use experimental data from sensor measurements collected by
running various tests on a system in real time. The measured data is then
sent to the adaptive table block to generate a lookup table describing the
relation between the system inputs and output.

The Adaptive Lookup Table block may also be used in a real-time environment,
where some time-varying properties of a system need to be captured. This can
be done by generating C code using Real-Time Workshop® code generation
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software which can then be run in an xPC Target™ or dSPACE® software.
Since the adaptation may be started, stopped, or reset if desired, some logic
may be used to adapt the table data only when it is desired. The Cell No
output, and the Enable and Lock inputs facilitate this process. The Enable
input is used to start and stop the adaptation, while the Lock input is used to
update only one of the table cells. The Lock input combined with some logic
using the Cell No output provide the means for updating only the desired
table cells during a simulation run.

Setting Adaptive Lookup Table Parameters
The Adaptive Lookup Table parameters are configured in the Function Block
Parameters dialog box. Double-click the Adaptive Lookup Tables Simulink
block to open the dialog box shown in the next figure.
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n-D Adaptive Lookup Table Dialog Box

For details on how to set these parameters, see the individual Chapter 9,
“Block Reference” reference pages.

Selecting an Adaptation Method
You can choose Sample mean or Sample mean (with forgetting) as the
Adaptation Method in the Function Block Parameters dialog box. This
section discusses the details of these algorithms.
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Sample Mean
Sample mean provides the average value of n output data samples and is
defined as:
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n
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where d(i) is the ith measurement collected within a particular cell. For each
input data pair(x1, x2), the sample mean at the corresponding cell is
updated using the output data measurement, d. Instead of accumulating n
samples of data for each cell, a recursive relation is used to calculate the
sample mean. The recursive expression is obtained as follows:
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where d(n) is the nth data sample. Defining a priori estimation error as

e n d n y n( ) ( ) ( )= − − 1 , the recursive relation can be written as:

y n y n
n

e n( ) ( ) ( )= − +1
1

where n ≥ 1 and the initial estimate y(0) is arbitrary.

In this expression, instead of n data samples, only the number of samples,
n, for each cell is stored in memory.

Sample Mean with Forgetting
The adaptation method “Sample Mean” on page 7-9 has an infinite memory.
The past data samples have the same weight as the final sample in calculating
the sample mean. Sample mean (with forgetting) uses an algorithm with
a forgetting factor or Adaptation gain that puts more weight on the more
recent samples. This algorithm provides robustness against initial response
transients of the plant and an adjustable speed of adaptation. Sample mean
(with forgetting) is defined as:
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priori estimation error as e n d n y n( ) ( ) ( )= − − 1 , where n ≥ 1 and the initial
estimate y(0) is arbitrary, the recursive relation can be written as:
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A small value of λ results in faster adaptation. A value of 0 indicates short
memory (last data becomes the table value), and a value of 1 indicates long
memory (average all data received in a cell).
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Example: n-D Adaptive Lookup Table

In this section...

“Loading the Example” on page 7-11

“Running the Example” on page 7-12

Loading the Example
This example shows an n-D adaptive lookup table at work and includes many
of the key features associated with adaptive lookup tables. Type

enginetable

at the MATLAB® prompt to open this model.

This model has several key features:
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• Input — The adaptive lookup table input is the experimental data. It is
also possible to make the original table itself an input.

• An enable feature — You can turn the adaptation on and off during the
estimation to see how the basic features work.

• A lock feature — You can lock the table so that only one cell is adapting.
This is useful if you have one section in your data that is highly erratic or
otherwise difficult for the algorithm to handle.

• Output — Adaptive lookup breakpoints are the output data.

Running the Example
To start the enginetable simulation, select Simulation > Start.
Alternatively, you can click the Start Simulation button in the Simulink®

toolbar.

The simulation begins by populating the adaptive lookup table with random
data. This figure shows the input and adaptive data side by side.

As the simulation progresses, the surface on the right adapts to match the
measured input data. This figure shows the final adaptation.
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The fit is quite good. Try using the enable and lock features to see how they
change the adaptation.
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Introduction
In addition to the Control and Estimation Tools Manager, you can also use
Simulink® Parameter Estimation™ functions to perform parameter and state
estimation. These functions perform the same tasks as the tools manager, but
have the advantages of command-line execution. When you perform a state or
parameter estimation using Simulink Parameter Estimation GUI, you create
MATLAB® objects for all the states and parameters of your model. If you have
a large number of states or parameters, this can use up large amounts of
memory and cause computational delays. With the command-line approach,
only those states and parameters that you select are assigned MATLAB
objects, which is more efficient.

In addition, the command-line approach is useful for batch jobs, where, for
example, you may want to test large numbers of models.

Note Simulink Parameter Estimation software uses MATLAB objects to
perform estimation tasks. This chapter discusses what you need to know
about object-oriented programming for using this product. See the MATLAB
Classes and Object-Oriented Programming documentation for a description of
object-oriented programming in MATLAB.

Simulink Parameter Estimation command-line interface requires a Simulink®

model as a starting point for analysis and estimation. Once you have selected
a candidate model, the estimation process consists of these steps:

1 Defining experiments consisting of empirical data sets and the operating
conditions and/or initial conditions of your model

2 Selecting the variables and states to be estimated

3 Performing the estimation

4 Reviewing the results and iterating as necessary

5 Validating estimation results
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The following sections discuss these topics:

• “Example: Estimating Parameters and Initial Conditions of the F14 Model”
on page 8-5 — How to perform the estimation process using command-line
functions

• “Creating and Customizing Estimation Projects” on page 8-15 — How to
use methods and properties to customize your estimation project’s features

8-4



Example: Estimating Parameters and Initial Conditions of the F14 Model

Example: Estimating Parameters and Initial Conditions
of the F14 Model

In this section...

“Loading the F14 Jet Model” on page 8-5

“Baseline Simulation” on page 8-6

“Creating a Transient Experiment Object” on page 8-8

“Assigning Experimental Data to Inputs and Outputs of the Model” on
page 8-9

“Creating Parameter Objects for Estimation” on page 8-10

“Creating an Estimation Object and Running the Estimation” on page 8-11

Loading the F14 Jet Model
To define an experiment, you must start with a Simulink® model. For this
example, type

f14

to load the F14 fighter jet model into the MATLAB® workspace. The following
figure shows the f14 model.
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F14 Fighter Jet Model

This example outlines the basics of constructing an estimation project using
object-oriented code. Only what you need to run the example is presented in
this section. See “Creating and Customizing Estimation Projects” on page
8-15 for details on all the properties and methods associated with parameter
estimation.

Baseline Simulation
Before running an estimation, you need a baseline for data comparison. First,
you must choose parameters and states’ initial conditions for estimation. This
example uses Ta, the actuator time constant, and Zd and Md, the vertical
velocity and pitch rate gains, respectively. Then use the following code to run
the Simulink f14 model. Note that this is standard Simulink code and does
not involve Simulink® Parameter Estimation™ command-line interface in any
way. See sim in the Simulink Reference documentation for information about
running Simulink models from the MATLAB command line.
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%% Open the model and load experimental data.
open_system('f14')
load f14_estim % Load empirical I/O data.

%% Set initialize unknown parameters
% Actuator time constant (ideal: Ta = 0.05)
Ta = 0.5;

% Aircraft dynamic model parameters (ideal: Md = -6.8847,
% Zd = -63.998)
Md = -1; Zd = -80;

%% Plot measured data and simulation results
[T,X,Y] = sim('f14', time, [], [time iodata(:,1)]);
plot(time, iodata(:,2:3), T, Y, '-');
legend( 'Measured angle of attack', 'Measured pilot g force', ...

'Simulated angle of attack', 'Simulated pilot g force');

The following figure appears.

8-7



8 Estimating from the Command Line

As you can see, the measured and simulated data are a poor match. The
rest of this section describes how to estimate values for Ta, Zd, and Md that
result in a better match of data sets.

Creating a Transient Experiment Object
After you have a model and identify the parameters you want to
estimate, the next step is to create the objects required for an estimation.
ParameterEstimator is both the name of the class and the object instantiated
by that class. Classes are created by a constructor; objects are created by
invoking the class name with parameters.

First, create an estimation project object. This is the constructor syntax:

hExp = ParameterEstimator.TransientExperiment('f14')

This command returns the following information about the f14 model.
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Experimental transient data set for the model 'f14':

Output Data
(1) f14/alpha (rad)
(2) f14/Nz Pilot (g)

Input Data
(1) f14/u

Initial States
(1) f14/Actuator Model
(2) f14/Aircraft Dynamics Model/Transfer Fcn.1
(3) f14/Aircraft Dynamics Model/Transfer Fcn.2
(4) f14/Controller/Alpha-sensor Low-pass Filter
(5) f14/Controller/Pitch Rate Lead Filter
(6) f14/Controller/Proportional plus integral compensator
(7) f14/Controller/Stick Prefilter
(8) f14/Dryden Wind Gust Models/Q-gust model
(9) f14/Dryden Wind Gust Models/W-gust model

Assigning Experimental Data to Inputs and Outputs
of the Model
After you create a ParameterEstimator object, assign input and output
experimental (i.e., empirical) data.

%% Create objects to represent the experimental data sets.
set(hExp.InputData(1), 'Data', iodata(:,1), 'Time', time);

set(hExp.OutputData(1), 'Data', iodata(:,2), 'Time', ...
time, 'Weight', 5);

set(hExp.OutputData(2), 'Data', iodata(:,3), 'Time', time);

Note In general, for models with multiple inputs and outputs, you must
independently assign one data object to each input and output port. The
data object you assign to a specific port can be a vector or a matrix that
corresponds to that channel. You cannot use a single I/O port to represent
multiple channels.
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Creating Parameter Objects for Estimation
To activate parameters for estimation, you must create parameter objects for
the parameters you want to estimate. For this example, use Ta, the actuator
time constant, and Zd and Md, the vertical velocity and pitch rate gains,
respectively. The Zd and Md gains are located in the F14 aircraft dynamics
subsystem.

First, create ParameterEstimator objects for the parameters you want to
estimate.

%% Create objects to represent parameters.
hPar(1) = ParameterEstimator.Parameter('Ta');
set(hPar(1), 'Minimum', 0.01, 'Maximum', 1, 'Estimated', true)

hPar(2) = ParameterEstimator.Parameter('Md');
set(hPar(2), 'Minimum', -10, 'Maximum', 0, 'Estimated', true)

hPar(3) = ParameterEstimator.Parameter('Zd');
set(hPar(3), 'Minimum', -100, 'Maximum', 0, 'Estimated', true)
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%% Create objects to represent initial states.
hIc(1) = ParameterEstimator.State('f14/Actuator Model');
set(hIc(1), 'Minimum', 0, 'Estimated', false);

You can also use dot notation here. For example, instead of

set(hPar(2), 'Minimum', -10, 'Maximum', 0, 'Estimated', true)

you can write

hPar(2).Estimated=true;
hPar(2).Minimum=-10;
hPar(2).Maximum=0;

Creating an Estimation Object and Running the
Estimation
Finally, create an estimation object and run the estimation, using gcs to get
the full pathname to the Simulink model.

hEst = ParameterEstimator.Estimation(gcs, hPar, hExp);
hEst.States = hIc;

%% Setup estimation options
hEst.OptimOptions.Algorithm = 'lsqnonlin';
hEst.OptimOptions.GradientType = 'refined';
hEst.OptimOptions.Display = 'iter';

%% Run the estimation
estimate(hEst);

%% Plot measured data and final simulation results
[T,X,Y] = sim('f14', time, [], [time iodata(:,1)]);
figure
plot(time, iodata(:,2:3), T, Y, '-');
legend( 'Measured angle of attack', 'Measured pilot g force', ...

'Simulated angle of attack', 'Simulated pilot g force');
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This figure shows the results of the estimation.

The measured and simulated outputs now appear to be a close match. Next,
look at the estimated values to see how they compare with the default values
of the f14 model.

%% Look at the estimated values
find(hEst.Parameters, 'Estimated', true)
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This command returns the following result:

(1) Parameter data for 'Ta':

Parameter value : 0.05
Initial guess : 0.5

Estimated : true

Referenced by:

(2) Parameter data for 'Md':

Parameter value : -6.884
Initial guess : -1

Estimated : true

Referenced by:

(3) Parameter data for 'Zd':

Parameter value : -63.99
Initial guess : -80

Estimated : true

Referenced by:
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Note You can use the find command to identify scalar, vector, or matrix
parameters. The dimensions of the Estimated value you specify as the find
argument must match the dimensions of the parameters you are trying to
find. For example,

find(hEst.Parameters, 'Estimated', true)

finds only scalar estimated parameters. However,

find(hEst.Parameters, 'Estimated', [true;true])

finds only vector estimated parameters with dimensions 1-by-2 and excludes
all scalar parameters.

You can verify that these values match the default values of the f14 model by
clearing your workspace, loading the model, and checking the values.

clear all
f14
whos
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Creating and Customizing Estimation Projects
The following sections describe in more detail how to create and modify
transient data and estimation objects:

• “Creating Transient Data Objects” on page 8-16

• “Creating State Data Objects” on page 8-21

• “Creating Transient Experiment Objects” on page 8-24

• “Creating Parameter Objects” on page 8-27

• “Creating State Objects” on page 8-31

• “Creating Estimation Objects” on page 8-35

First, a quick look at terminology:

• Objects are instantiations of classes.

• Classes contain, or rather, define, properties and methods.

• You use a constructor to create an instance of an object, and use the set
method or dot notation to modify the properties of your objects.
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Creating Transient Data Objects
• “What is a Transient Data Object” on page 8-16

• “Constructor” on page 8-16

• “Properties of Transient Data Objects” on page 8-17

• “Modifying Properties of Transient Data Objects” on page 8-19

• “Using Class Methods” on page 8-20

What is a Transient Data Object
The @TransientData object encapsulates the data measured at a single input
or output of a physical system during an experiment. Transient data objects
are associated with three types of Simulink® blocks:

• Inport blocks

• Outport blocks

• Internal blocks used in conjunction with signal logging.

Each @TransientData object describes the time history of a signal at a
Simulink port. A data set is identified by the Block property of this object
corresponding to a block name in the Simulink model. A PortNumber value
is also necessary for internal blocks to uniquely identify signals within the
block diagram.

Constructor
Estimating parameters requires a transient data object, which you create
using a constructor. The syntax to create a transient data object is

% I/O port block
h = ParameterEstimator.TransientData('block');
% Internal block
h = ParameterEstimator.TransientData('block',portnumber);

h = ParameterEstimator.TransientData('block',data,time);
h = ParameterEstimator.TransientData('block',data,Ts);
h = ParameterEstimator.TransientData('block',portnumber,data,time);
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h = ParameterEstimator.TransientData('block',portnumber,data,Ts);

Properties of Transient Data Objects
Descriptions of properties of the transient data object and the associated
input parameters are as follows.

Transient Data Object Properties

Property Description

Block Name of the Simulink block with which the data is
associated. Must be a string.

PortType The type of signal that this object represents is determined
in the constructor from the Block property, which may be
Inport, Outport, or Signal.

PortNumber For data associated with the outputs of regular blocks
or subsystems, this property specifies the output port
number of interest. The default value is 1.

Dimensions Dimensions of the data required for this data set. It is
computed from the CompiledPortDimensions property of
the appropriate port of the block, and it defines the size
of other properties. Currently, Simulink supports scalar,
vector, or matrix signals, so Dimensions is either a scalar
or a 1-by-2 array.

Data Actual experimental data. Its size must be consistent
with the Dimensions property. To conform with Simulink
conventions, the data is stored in the following formats:

• Scalar or vector-valued data. The data is of the form Ns
m, where Ns is the number of data samples, and m is
the number of channels in the signal.

• Multidimensional data (matrix and higher dimensions).
The data is of the form m1 . . . mn Ns, where Ns is
the number of data samples, and mi is the number of
channels in the ith dimension of the signal.

• For missing or unspecified data, NaNs are used.
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Transient Data Object Properties (Continued)

Property Description

Ts,
Tstart,
Tstop

For uniformly sampled data, Ts is the sample time and
Tstart is the start time of the signal. The stop time Tstop
and the time vector Time are given by

Tstop = Tstart + Ts * (Ns -1)

Time = Tstart : Ts : Tstop

For nonuniform time data, Ts is set to NaN, and the start
and stop times are calculated from the time vector.

Time The time data in column vector format. The length of Time
must be consistent with the number of samples in Data.

For a nonuniformly spaced Time vector, its length should
match the length of Data.

Otherwise, Time is automatically adjusted based on the
length of Data.

Modifying Ts resets Time internally. In this case, Time is
a virtual property whose value is computed from Ts and
Tstart when you request it. The rules for setting time
related properties are

• Modifying Time sets

Ts = NaN
Tstart = Time(1)

• If the time vector is uniformly spaced, a sample time
Ts is calculated.

• Modifying Tstart translates time forward or backward.

• Modifying Ts sets Time = [] internally and generates
it when required by the simulation.
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Transient Data Object Properties (Continued)

Property Description

Weight The weight associated with each channel of this data set.
It is used to specify the relative importance of signals.
The default value is 1.

InterSample Interpolation method between samples can be zero-order
hold (zoh) or first-order hold (foh). This property is used
for data preprocessing.

Modifying Properties of Transient Data Objects
After a transient data object is created, you can modify its properties using
this syntax:

in1.Data = rand(2,1,10); % 10 data values each of size [2 1]
in1.Time = 1:10; % Automatically converted to column vector

Some properties (e.g., Weight) support scalar expansion with respect to the
value of the Dimensions property.

Example: Assigning Input Port Data
To assign data to an input port with 2-by-3 port dimensions, use

in1 = ParameterEstimator.TransientData(gcb, rand(2,3,100), 0.05)

This command returns the following result:

(1) Transient data for Inport block 'portdata_test_noSim/By//Pass
Air Valve Voltage':
Sampling interval: 0.05 sec.
Data set has 100 samples and 6 channels.
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Using Class Methods
Descriptions of two important methods are given next:

• select — Extracts a portion of data. The result is returned in a new
transient data object.

in2 = select(in1, 'Sample', 10:100); % 91 samples
in3 = select(in1, 'Range', [1 4]); % Samples for 1<t<4
% ... or an alternative
in3 = select(in1, 'Sample', find(in1.Time > 1 & in1.Time < 4));

To extract data from a subset of available channels, use

in4 = select(in1, 'Channel', [1 3 2]);
% channels 1,3,and 2 in this order

• hiliteBlock — Highlights the block associated with this object in the
Simulink diagram.
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Creating State Data Objects

In this section...

“What is a State Data Object” on page 8-21

“Constructor” on page 8-21

“Properties of the State Data Object” on page 8-22

“Example: Initial Condition Data” on page 8-23

“Modifying Properties” on page 8-23

“Using Class Methods” on page 8-23

What is a State Data Object
The ParameterEstimator.StateData object defines the states of a dynamic
Simulink® block. It is used in a transient estimation context to define known
initial conditions of a block diagram model, and in a steady-state estimation
context to define the known states of the model.

For example, the Simulink model of a simple mass-spring-damper system
has two integrator blocks to generate velocity and position signals from
acceleration and velocity values, respectively, during simulation. If the
corresponding physical system is known to be at rest at the beginning of an
experiment, the initial states (velocity and position) of these integrators are
zero. So, two @StateData objects can be created to describe these known
initial conditions.

Constructor
The syntax for creating this object is

h = ParameterEstimator.StateData('block');
h = ParameterEstimator.StateData('block', data);

In the first constructor, the state vector is initialized from the model
containing the block.
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Properties of the State Data Object
Descriptions of some important properties are given in the following table .

State Data Object Properties

Property Description

Block Name of the Simulink block whose states are defined
by this object.

Dimensions Scalar value to store the number of states of the relevant
block.

Data Column vector to store the initial value of the state
for the block specified by this object. The length of
this vector should be consistent with the Dimensions
property. Since the underlying Simulink model also
stores an initial state vector for all dynamic blocks, the
following conventions are used to resolve the initial state
values during estimations:

• If Data is not empty, use it when forming the state
vector.

• If Data is empty, get the state vector for this block
from the model. This behavior is useful when using
helper methods to create an experiment object that
instantiates empty state data objects for all dynamic
blocks in the Simulink model.

• If there is no state data object for a dynamic block in
the model, get the state vector of that block from the
model. This behavior is useful for command-line users,
when there are too many states in the model and only
a few of them have to be set to different initial values.

Ts Sampling time of discrete blocks. Set to 0 for continuous
blocks. This property is read only and is currently used
for information only.

Domain String to hold the physical domain of the block. Used for
SimMechanics or SimPowerSystems blocks with states.
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Example: Initial Condition Data
To create an empty initial condition object for the engine_idle_speed/
TransferFcn2, use

st1 = ParameterEstimator.StateData ...
('engine_idle_speed/Transfer Fcn2', [1 2])

(1) State data for 'f14/Dryden Wind Gust Models/W-gust model'
block:
The block has 2 continuous state(s).
State value : [1;2]

Modifying Properties
After a state data object is created, you can modify its properties using this
syntax:

st1.Data = [2 3]; % State vector of size 2

Some properties (e.g., Data) support scalar expansion with respect to the
value of the Dimensions property.

Using Class Methods
Description of two important methods are given next:

• hiliteBlock — Highlights the block associated with this object in the
Simulink diagram.

• update — Updates the object after the Simulink model has been modified.
If the Dimensions property value changes, the other properties are reset to
their default values.
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Creating Transient Experiment Objects

In this section...

“What is a Transient Experiment Object” on page 8-24

“Constructor” on page 8-24

“Properties of Transient Experiment Objects” on page 8-24

“Example: Creating an F14 Experiment” on page 8-25

“Example: Creating a Van der Pol Experiment from User Objects” on page
8-26

“Modifying Properties” on page 8-26

“Using Class Methods” on page 8-26

What is a Transient Experiment Object
The @TransientExperiment object encapsulates the data measured at the
input and output ports of a system during a single experiment, as well as the
system’s known initial states.

Constructor
The syntax to create a transient experiment object is

h = ParameterEstimator.TransientExperiment('model');

where model specifies the name of the Simulink® model.

Properties of Transient Experiment Objects
Descriptions of some important properties are given in the following table.

Transient Experiment Object Properties

Property Description

Model Simulink model with which this experiment is
associated.
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Transient Experiment Object Properties (Continued)

Property Description

InputData,
OutputData

Transient data objects associated with appropriate I/O
blocks in the model. Blocks with unassigned objects
or objects with no data are not used in estimations,
meaning:

• For input ports, assign zeros to these ports/channels
during simulation.

• For output ports, don’t use these ports/channels in
the cost function.

InitialStates State data objects associated with appropriate dynamic
blocks in the model.

InitFcn Function to be executed to configure the model for this
particular experiment.

Example: Creating an F14 Experiment
To create an empty transient experiment for the f14 model, use

exp1 = ParameterEstimator.TransientExperiment('f14')
Experimental (Transient) data set for the model 'f14':
Outputs
(1) f14/alpha (rad)
(2) f14/Nz Pilot (g)
Inputs
(1) f14/u
Initial States
(1) f14/Actuator Model
(2) f14/Aircraft Dynamics Model/Transfer Fcn.1
(3) f14/Aircraft Dynamics Model/Transfer Fcn.2
(4) f14/Controller/Alpha-sensor Low-pass Filter
(5) f14/Controller/Pitch Rate Lead Filter
(6) f14/Controller/Proportional plus integral compensator
(7) f14/Controller/Stick Prefilter
(8) f14/Dryden Wind Gust Models/Q-gust model
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(9) f14/Dryden Wind Gust Models/W-gust model

Example: Creating a Van der Pol Experiment from
User Objects
To create a transient experiment from user objects for I/Os and states, use

out1 = ParameterEstimator.TransientData('vdp/Out1');
ic1 = ParameterEstimator.StateData('vdp/x1');
exp1 = ParameterEstimator.TransientExperiment...
(gcs, [], out1, ic1);
Experimental (Transient) data set for the model 'vdp':
Outputs
(1) vdp/Out1
Inputs
(none)
Initial States
(1) vdp/x1

Modifying Properties
The objects referred in InputData, OutputData, and InitialStates
properties can be modified or removed as necessary.

Using Class Methods
The description of one important method is given next:

update — Updates the object after the Simulink model has been modified.
The object listed in the InputData, OutputData, and InitialStates
properties are updated in turn.
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Creating Parameter Objects

In this section...

“What is a Parameter Object” on page 8-27

“Constructor” on page 8-27

“Properties of Parameter Objects” on page 8-27

“Example: F14 Model” on page 8-29

“Example: Gain Matrix” on page 8-30

“Modifying Properties” on page 8-30

“Using Class Methods” on page 8-30

What is a Parameter Object
The @Parameter object refers to the parameters of the Simulink® model
marked for estimation. Some of the Simulink model parameters are to be
estimated and storage is required for the initial values, current values, ranges,
etc. One @Parameter object corresponds to each parameter in the Simulink
model to be potentially estimated. These objects represent estimation
parameters of any type such as scalars, vectors, and multidimensional arrays.

Constructor
The syntax to create a parameter object is

h = ParameterEstimator.Parameter('Name');
h = ParameterEstimator.Parameter('Name', Value);
h = ParameterEstimator.Parameter('Name', Value, Minimum,

Maximum);

In the first case, Name is a workspace variable. In the other cases, Name does
not need to exist in the workspace at the time of object creation. However, it is
required at estimation time.

Properties of Parameter Objects
Descriptions of some important properties are given in the following table.
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Parameter Object Properties

Property Description

Name Parameter name. The parameter can be a
multidimensional array of any size.

Dimensions Dimensions of the value of the parameter. This is the
defining property for the size of other properties.

Value The current or estimated value of the parameter. This
is the defining property for size checking and scalar
expansions.

Estimated A Boolean array of the same size as that of Value.
Depending on the value of the elements of the Estimated
property, the behavior of the corresponding elements of
Value is as follows:

• The elements of Value is estimated if the corresponding
elements in Estimate are set to true. The result is
stored in the Value property.

• The elements of Value are not estimated if the
corresponding elements in Estimated are set to
false. However, these elements are used to reset
the corresponding workspace parameter during
estimations.

This property is set to false by default, meaning that
the parameter value is not estimated.
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Parameter Object Properties (Continued)

Property Description

InitialGuess Separate properties are required to hold the initial
and current values of the parameters. So, when the
InitialGuess property is initialized with a value, both it
and the Value property are assigned the same value.
Depending on the value of the elements of the Estimated
property, the behavior of the corresponding elements of
InitialGuess is as follows:

• If any element in Estimated is set to true, then the
corresponding element of InitialGuess is used to
initialize the workspace parameter during estimations.

• If any element in Estimated is set to false, then the
corresponding element of InitialGuess is not used
in any way.

Minimum,
Maximum

Parameter range.

TypicalValue The typical values of the parameters. This property is
used in estimations for scaling purposes. The default
value is 1.

Example: F14 Model
To create a parameter object for the parameter Ta in the f14 model, use

par1 = ParameterEstimator.Parameter('Ta')
(1) Parameter data for 'Ta':
Parameter value : 0.05
Initial value : 0.05
Estimated : false
Referenced by the blocks:
f14/Actuator Model
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Example: Gain Matrix
To create a parameter object for a matrix parameter K of size 4-by-1, use

par1 = ParameterEstimator.Parameter('K', [1 2 3 4]')
(1) Parameter data for 'K':
Parameter value : [1;2;3;4]
Initial value : [1;2;3;4]
Estimated elements : [false;false;false;false]
Referenced by the blocks:

Modifying Properties
After a parameter object is created, you can modify its properties using this
syntax:

par1.Estimated = true; % Estimate this parameter

Most of the properties, for example, Estimated and TypicalValue support
scalar expansion with respect to the size of Value.

Using Class Methods
Descriptions of two important methods are given next:

• hiliteBlock — Highlights the referenced blocks associated with
parameter objects in the Simulink diagram.

• update — Updates the parameter object after the Simulink model has
been modified. If the size of the Value property changes, then the other
properties are reset to their default values.
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Creating State Objects

In this section...

“What is a State Object” on page 8-31

“Constructor” on page 8-31

“Properties of State Objects” on page 8-31

“Example: F14 Model” on page 8-33

“Modifying Properties” on page 8-34

“Using Class Methods” on page 8-34

What is a State Object
The @State object is similar to the @Parameter object. One @State object
corresponds to each Simulink® block with states in the model.

Constructor
The syntax to create a state object is

h = ParameterEstimator.State('block');
h = ParameterEstimator.State('block', Value);
h = ParameterEstimator.State('block', Value, Minimum,

Maximum);

In the first case, the state vector is initialized from the model containing the
block. In the other cases, block does not need to exist in the workspace at
the time of object creation. However, it is required at estimation time.

Properties of State Objects
Descriptions of some important properties of state objects are given in the
following table.
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State Object Properties

Property Description

Block Name of the Simulink block whose states are defined
by this object.

Dimensions Scalar value to store the number of states of the relevant
block.

Value Column vector to store the value of the state for the
block specified by this object. The length of this vector
should be consistent with the Dimensions property.

Estimated A Boolean array of the same size as that of Value.
Depending on the value of the elements of the Estimated
property, the behavior of the corresponding elements of
Value is as follows:

• The elements of Value are estimated if the
corresponding elements in Estimate are set to true.
The result is stored in the Value property.

• The elements of Value are not estimated if the
corresponding elements in Estimated are set to
false. However, these elements are used to reset the
corresponding states during estimations.

This property is set to false by default, meaning that
the state value is not estimated.
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State Object Properties (Continued)

Property Description

InitialGuess Separate properties are required to hold the initial and
current values of the states. So, when the InitialGuess
property is initialized with a value, both it and the
Value property are assigned the same value.
Depending on the value of the elements of the Estimated
property, the behavior of the corresponding elements of
InitialGuess is as follows:

• If any element in Estimated is set to true, then the
corresponding element of InitialGuess is used to
initialize the state during estimations.

• If any element in Estimated is set to false, then the
corresponding element of InitialGuess is not used
in any way.

Minimum,
Maximum

State vector range.

TypicalValue The typical values of the states. This property is used in
estimations for scaling purposes. The default value is 1.

Ts Sampling time of discrete blocks. Set to zero for
continuous blocks. This property is read-only and is
currently used for information only.

Domain String to hold the physical domain of the block. Used for
SimMechanics™ or SimPowerSystems™ blocks with
states.

Example: F14 Model
To create a state object for the f14/Actuator Model block in the f14 model,
use

st1 = ParameterEstimator.State(gcb)

This command returns the following result:
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(1) State data for f14/Actuator Model block:

The block has 1 continuous state(s).

State value : 0
Initial guess : 0

Estimated : false

Modifying Properties
After a state object is created, you can modify its properties using this syntax:

ic1.Estimated = true; % Estimate this state

Most of the properties, for example, Estimated and TypicalValue, support
scalar expansion with respect to the size of Value.

Using Class Methods
Description of two important methods are given next:

• hiliteBlock — Highlights the referenced blocks associated with state
objects in the Simulink diagram.

• update — Updates the state object after the Simulink model has been
modified. If the size of Value property changes, then the other properties
are reset to their default values.
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Creating Estimation Objects

In this section...

“What is an Estimation Object” on page 8-35

“Constructor” on page 8-35

“Properties of Estimation Objects” on page 8-35

“Example: F14 Model” on page 8-37

“Modifying Properties” on page 8-37

“Using Class Methods” on page 8-37

What is an Estimation Object
The @Estimation object is the coordinator between the model, experiments,
and parameter objects.

Constructor
The @Estimation object is the coordinator of the model, experiment, and
parameter objects. The syntax to create an estimation object is

h = ParameterEstimator.Estimation('model');
h = ParameterEstimator.Estimation('model', hParam);
h = ParameterEstimator.Estimation('model', hParam, hExps);

Properties of Estimation Objects
Descriptions of some important properties of estimation objects are given
in the following table.

Estimation Object Properties

Property Description

Model Name of the Simulink® model with which this estimation
is associated.
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Estimation Object Properties (Continued)

Property Description

Experiments Experiments to be used in estimations. For multiple
experiments, the cost function uses a concatenation of the
output error vectors obtained using each experimental
data set.

Parameters Parameter objects to be used in estimations.

States State objects to be used in estimations. This is a handle
matrix with as many columns as there are experiments,
and as many rows as there are states in Model.
The handle matrix is created automatically in the
constructor. You can reorganize its rows to specify shared
states between experiments, and set the Estimated flag
of desired states.
If state data is provided in an experiment, the state
objects stored in the columns of this matrix are initialized
from the experiments.

SimOptions Same as simset structure. This property is initialized to
simget(this.Model).

OptimOptions Same as optimset structure.

EstimInfo This property is used to store estimation-related
information at each iteration of the optimizer, and is
initialized as

this.EstimInfo = struct( 'Cost', [],...
'Covariance', [],...
'FCount', [],...
'FirstOrd', [],...
'Gradient', [],...
'Iteration', [],...
'Procedure', [],...
'StepSize', [],...
'Values', [] );
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Example: F14 Model
To create an estimation object for the f14 model to estimate the parameters
Ta and Kf and two states, use

exp1 = ParameterEstimator.TransientExperiment(gcs);
par1 = ParameterEstimator.Parameter('Ta', 'Estimated', true);
par2 = ParameterEstimator.Parameter('Kf', 'Estimated', true);
est1 = ParameterEstimator.Estimation(gcs, [par1, par2], exp1);
est1.States(1,1).Estimated = true;
est1.States(6,1).Estimated = true;
est1

This command returns the following result:

Estimated variables for the model 'f14':

Estimated Parameters

Using Experiments
(1) f14 experiment

Estimated States for Experiment 'f14 experiment'
(1) f14/Actuator Model
(6) f14/Controller/Proportional plus integral compensator

Modifying Properties
After an estimation object is created, you can modify its properties using
this syntax:

est.OptimOptions.Algorithm = 'fmincon'; % Estimation method
est.OptimOptions.Display = 'iter'; % Show estimation information
...in workspace
est.Parameters(1).Estimated = false; % Do not estimate first
...parameter
est.States(2,3).Estimated = false; % Do not estimate second state
...of third expression

Using Class Methods
Descriptions of some of the important methods are given next:
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• compare — Compares an experiment and a simulation.

• simulate — Simulates the model with current parameters and states.

• estimate — Runs an estimation.

• restart — Restarts an estimation after it has finished running.

• update — Updates the estimation object after the Simulink model has
been modified.
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Block Reference

Adaptive Lookup Table (1D Stair-Fit)
Adaptive Lookup Table (2D Stair-Fit)
Adaptive Lookup Table (nD Stair-Fit)



Adaptive Lookup Table (1D Stair-Fit)

Purpose Perform one-dimensional adaptive table lookup

Description
The Adaptive Lookup Table (1D Stair-Fit) block creates a
one-dimensional adaptive lookup table by dynamically updating the
underlying lookup table. The block uses the outputs, ydata, of your
system to do the adaptations.

Each indexing parameter U may take a value within a set of adapting
data points, which are called breakpoints. Two breakpoints in each
dimension define a cell. The set of all breakpoints in one of the
dimensions defines a grid. In the one-dimensional case, each cell has
two breakpoints, and the cell is a line segment.

You can use the Adaptive Lookup Table (1D Stair Fit) block to model
time-varying systems.

Data Type
Support

Doubles only
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Dialog
Box

First input (row) breakpoint set
The vector of values containing possible block input values. The
input vector must be monotonically increasing.

Make initial table an input
Selecting this check box forces the Adaptive Lookup Table (1D
Stair-Fit) block to ignore the Table data (initial) parameter.
Instead, a new port appears with Tin next to it. Use this port
to input table data.

Table data (initial)
The initial table output values. This vector must be of size N-1,
where N is the number of breakpoints.
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Adaptive Lookup Table (1D Stair-Fit)

Table numbering data
Number values assigned to cells. This vector must be the same
size as the table data vector, and each value must be unique.

Adaptation method
Choose Sample mean or Sample mean (with forgetting).
Sample mean averages all the values received within a cell.
Sample mean with forgetting gives more weight to the new
data. How much weight is determined by the Adaptation gain
parameter. For more information, see “Selecting an Adaptation
Method” on page 7-8.

Adaptation gain (0 to 1)
A number between 0 and 1 that regulates the weight given to new
data during the adaptation. A 0 means short memory (last data
becomes the table value), and 1 means long memory (average all
data received in a cell).

Make adapted table an output
Selecting this check box creates an additional output port for the
adapted table.

Add adaptation enable/disable/reset port
Add an input port that enables, disables, or resets the adaptive
lookup table. 0 = disable; 1 = enable; 2 = reset to initial table data.

Add cell lock enable/disable port
A port that provides the means for updating only specified cells
during a simulation run. 0 = unlock; 1 = lock current cell.

Action for out-of-range input
Ignore or Adapt by extrapolating beyond the extreme breakpoints.

9-4



Adaptive Lookup Table (2D Stair-Fit)

Purpose Perform two-dimensional adaptive table lookup

Description
The Adaptive Lookup Table (2D Stair-Fit) block creates a
two-dimensional adaptive lookup table by dynamically updating the
underlying lookup table. The block uses the outputs (ydata) of your
system to do the adaptations.

Each indexing parameter U may take a value within a set of adapting
data points, which are called breakpoints. Two breakpoints in each
dimension define a cell. The set of all breakpoints in one of the
dimensions defines a grid. In the two-dimensional case, each cell has
four breakpoints and is a flat surface.

You can use the Adaptive Lookup Table (2D Stair-Fit) block to model
time-varying systems.
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Adaptive Lookup Table (2D Stair-Fit)

Dialog
Box

First input (row) breakpoint set
The vector of values containing possible block input values for the
first input variable. The first input vector must be monotonically
increasing.

Second input (column) breakpoint set
The vector of values containing possible block input values for
the second input variable. The second input vector must be
monotonically increasing.
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Adaptive Lookup Table (2D Stair-Fit)

Make initial table an input
Selecting this check box forces the Adaptive Lookup Table (2D
Stair-Fit) block to ignore the Table data (initial) parameter.
Instead, a new port appears with Tin next to it. Use this port
to input table data.

Table data (initial)
The initial table output values. This 2-by-2 matrix must be of size
(n-1)-by-(m-1), where n is the number of first input breakpoints
and m is the number of second input breakpoints.

Table numbering data
Number values assigned to cells. This matrix must be the same
size as the table data matrix, and each value must be unique.

Adaptation method
Choose Sample mean or Sample mean with forgetting. Sample
mean averages all the values received within a cell. Sample mean
with forgetting gives more weight to the new data. How much
weight is determined by the Adaptation gain parameter. For
more information, see “Selecting an Adaptation Method” on page
7-8.

Adaptation gain (0 to 1)
A number from 0 to 1 that regulates the weight given to new
data during the adaptation. A 0 means short memory (last data
becomes the table value), and 1 means long memory (average all
data received in a cell).

Make adapted table an output
Selecting this check box creates an additional output port for the
adapted table.

Add adaptation enable/disable/reset port
Add an input port that enables, disables, or resets the adaptive
lookup table.

Add cell lock enable/disable port
A port that provides the means for updating only specified cells
during a simulation run.
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Adaptive Lookup Table (2D Stair-Fit)

Action for out-of-range input
Ignore or Adapt by extrapolating beyond the extreme breakpoints.
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Adaptive Lookup Table (nD Stair-Fit)

Purpose Create adaptive lookup table of arbitrary dimension

Description
The Adaptive Lookup Table (nD Stair-Fit) block creates an adaptive
lookup table of arbitrary dimension by dynamically updating the
underlying lookup table. The block uses the outputs of your system to
do the adaptations.

Each indexing parameter may take a value within a set of adapting data
points, which are called breakpoints. Breakpoints in each dimension
define a cell. The set of all breakpoints in one of the dimensions defines
a grid. In the n-dimensional case, each cell has two n breakpoints and
is an (n-1) hypersurface.

You can use the Adaptive Lookup Table (nD Stair-Fit) block to model
time-varying systems.

9-9



Adaptive Lookup Table (nD Stair-Fit)

Dialog
Box

Number of table dimensions
The number of dimensions for the adaptive lookup table.

Table breakpoints (cell array)
A set of one-dimensional vectors that contains possible block
input values for the input variables. Each input row must be
monotonically increasing, but the rows do not have to be the same
length. For example, if the Number of table dimensions is 3,
you can set the table breakpoints as follows:

{[1 2 3], [5 7], [1 3 5 7]}
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Adaptive Lookup Table (nD Stair-Fit)

Make initial table an input
Selecting this check box forces the Adaptive Lookup Table (nD
Stair-Fit) block to ignore the Table data (initial) parameter.
Instead, a new port appears with Tin next to it. Use this port
to input table data.

Table data (initial)
The initial table output values. This (n-D) array must be of size
(n-1)-by-(n-1) ... -by- (n-1), (D times), where D is the number of
dimensions and n is the number of input breakpoints.

Table numbering data
Number values assigned to cells. This vector must be the same
size as the table data array, and each value must be unique.

Adaptation method
Choose Sample mean or Sample mean with forgetting. Sample
mean averages all the values received within a cell. Sample mean
with forgetting gives more weight to the new data. How much
weight is determined by the Adaptation gain parameter. For
more information, see “Selecting an Adaptation Method” on page
7-8.

Adaptation gain (0 to 1)
A number from 0 to 1 that regulates the weight given to new
data during the adaptation. A 0 means short memory (last data
becomes the table value), and 1 means long memory (average all
data received in a cell).

Make adapted table an output
Selecting this check box creates an additional output port for the
adapted table.

Add adaptation enable/disable/reset port
Add an input port that enables, disables, or resets the adaptive
lookup table.

Add cell lock enable/disable port
A port that provides the means for updating only specified cells
during a simulation run.
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Adaptive Lookup Table (nD Stair-Fit)

Action for out-of-range input
Ignore or Adapt by extrapolating beyond the extreme breakpoints.

9-12



10

Function Reference



spetool

Purpose Open Simulink Parameter Estimation GUI

Syntax spetool('modelname')

Description spetool('modelname') opens Simulink Parameter Estimation GUI for
the Simulink model with the name modelname.

See Also For more information on estimating parameters using Simulink
Parameter Estimation GUI, see Chapter 1, “Getting Started”.
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A

Examples

Use this list to find examples in the documentation.



A Examples

Getting Started
Chapter 2, “Tutorial — Preparing Data for Parameter Estimation Using
the GUI”
Chapter 3, “Tutorial — Estimating Parameters from Measured Data Using
the GUI”
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